GLSA-202211-02:lesspipe:任意程式碼執行

critical Nessus Plugin ID 167257

語系:

描述

遠端主機受到 GLSA-202211-02 中所述的弱點影響 (lesspipe:任意程式碼執行)

- lesspipe 2.06 之前版本允許攻擊者透過 Perl Storable (pst) 檔案執行程式碼,這是透過雜湊中的金鑰/值對執行還原序列化的物件解構函式所引致。(CVE-2022-44542)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

所有 lesspipe 使用者皆應更新至最新版本:

# emerge --sync # emerge --ask --oneshot --verbose >=app-text/lesspipe-2.06

另請參閱

https://security.gentoo.org/glsa/202211-02

https://bugs.gentoo.org/show_bug.cgi?id=865631

Plugin 詳細資訊

嚴重性: Critical

ID: 167257

檔案名稱: gentoo_GLSA-202211-02.nasl

版本: 1.2

類型: local

已發布: 2022/11/10

已更新: 2022/11/10

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: CVSS2#E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-44542

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: cpe:2.3:o:gentoo:linux:*:*:*:*:*:*:*:*, p-cpe:2.3:a:gentoo:linux:lesspipe:*:*:*:*:*:*:*

必要的 KB 項目: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/11/10

弱點發布日期: 2022/11/1

參考資訊

CVE: CVE-2022-44542