Ubuntu 18.04 LTS / 20.04 LTS / 22.04 LTS / 22.10:pixman 弱點 (USN-5718-1)

high Nessus Plugin ID 167196

Synopsis

遠端 Ubuntu 主機缺少安全性更新。

描述

遠端 Ubuntu 18.04 LTS/20.04 LTS/22.04 LTS/22.10 主機上安裝的套件受到 USN-5718-1公告中所提及的一個弱點影響。

- 在 Pixman 0.42.2 之前版本的 libpixman 中,由於 pixman_sample_floor_y 中存在整數溢位問題,導致 rasterize_edges_8 中發生超出邊界寫入 (即堆積型緩衝區溢位)。(CVE-2022-44638)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

更新受影響的 libpixman-1-0 和/或 libpixman-1-dev 套件。

另請參閱

https://ubuntu.com/security/notices/USN-5718-1

Plugin 詳細資訊

嚴重性: High

ID: 167196

檔案名稱: ubuntu_USN-5718-1.nasl

版本: 1.5

類型: local

代理程式: unix

已發布: 2022/11/9

已更新: 2023/1/17

支持的傳感器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 7.8

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:POC/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-44638

CVSS v3

風險因素: High

基本分數: 8.8

時間分數: 7.9

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/o:canonical:ubuntu_linux:18.04:-:lts, cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:22.04:-:lts, cpe:/o:canonical:ubuntu_linux:22.10, p-cpe:/a:canonical:ubuntu_linux:libpixman-1-0, p-cpe:/a:canonical:ubuntu_linux:libpixman-1-dev

必要的 KB 項目: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2022/11/8

弱點發布日期: 2022/11/3

參考資訊

CVE: CVE-2022-44638

USN: 5718-1