Amazon Linux 2022: (ALAS2022-2022-181)

medium Nessus Plugin ID 167028

Synopsis

遠端 Amazon Linux 2022 主機缺少一個安全性更新。

描述

因此,會受到 ALAS2022-2022-181 公告中提及的一個弱點影響。

- HarfBuzz 2.9.0 的 hb_bit_set_invertible_t: : set (從 hb_sparseset_t<hb_bit_set_invertible_t>: : set 和 hb_set_copy 呼叫) 中存在超出邊界寫入問題。(CVE-2021-45931)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

執行「dnf update harfbuzz --releasever=2022.0.20221102」以更新系統。

另請參閱

https://alas.aws.amazon.com/AL2022/ALAS-2022-181.html

https://alas.aws.amazon.com/cve/html/CVE-2021-45931.html

Plugin 詳細資訊

嚴重性: Medium

ID: 167028

檔案名稱: al2022_ALAS2022-2022-181.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2022/11/5

已更新: 2022/11/5

支持的傳感器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: AV:N/AC:M/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-45931

CVSS v3

風險因素: Medium

基本分數: 6.5

時間分數: 5.7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:amazon:linux:harfbuzz, p-cpe:/a:amazon:linux:harfbuzz-debuginfo, p-cpe:/a:amazon:linux:harfbuzz-debugsource, p-cpe:/a:amazon:linux:harfbuzz-devel, p-cpe:/a:amazon:linux:harfbuzz-devel-debuginfo, p-cpe:/a:amazon:linux:harfbuzz-icu, p-cpe:/a:amazon:linux:harfbuzz-icu-debuginfo, cpe:/o:amazon:linux:2022

必要的 KB 項目: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/11/1

弱點發布日期: 2022/1/1

參考資訊

CVE: CVE-2021-45931