PHP 7.4.x < 7.4.33 多個弱點

critical Nessus Plugin ID 166901

Synopsis

遠端 Web 伺服器上執行的 PHP 版本受到多個弱點影響。

描述

遠端主機上安裝的 PHP 版本為 7.4.33 之前的版本。因此,它受到 7.4.33 版公告中所提及的多個弱點影響。

- 在 fdc6fef 之前的 Keccak XKCP SHA-3 參照實作中發現整數溢位問題和由此產生的緩衝區溢位,攻擊者可以藉此執行任意程式碼或消除預期的密碼編譯屬性。
這問題發生在 sponge 函式介面中。(CVE-2022-37454)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 PHP 7.4.33 版或更新版本。

另請參閱

http://bugs.php.net/81738

http://bugs.php.net/81739

http://php.net/ChangeLog-7.php#7.4.33

Plugin 詳細資訊

嚴重性: Critical

ID: 166901

檔案名稱: php_7_4_33.nasl

版本: 1.7

類型: remote

系列: CGI abuses

已發布: 2022/11/3

已更新: 2023/1/12

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: High

分數: 8.4

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 7.4

媒介: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

時間媒介: CVSS2#E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-37454

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

必要的 KB 項目: www/PHP, installed_sw/PHP

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/11/3

弱點發布日期: 2022/10/21

參考資訊

CVE: CVE-2022-37454, CVE-2022-31630

IAVA: 2022-A-0455-S, 2022-A-0515-S