OpenSSL 3.0.0 < 3.0.7 多個弱點

high Nessus Plugin ID 166773

Synopsis

遠端服務受到多種弱點的影響。

描述

遠端主機上安裝的 OpenSSL 為 3.0.7 之前版本。因此,會受到 3.0.7 公告中所提及的多個弱點影響。

- 在 X.509 憑證驗證中可觸發緩衝區滿溢,特別是在名稱限制檢查中。請注意,此問題會在憑證鏈簽章驗證之後發生,且需要 CA 簽署惡意憑證,或是即使無法建構受信任的簽發者路徑,應用程式仍需繼續進行憑證驗證。攻擊者可在憑證中建構惡意電子郵件地址,造成堆疊中溢出任意數量包含「.」的位元組 (十進位 46)。此緩衝區溢位問題可能會導致當機 (造成拒絕服務攻擊)。在 TLS 用戶端中,藉由連線至惡意伺服器即可觸發此問題。在 TLS 伺服器中,如果伺服器要求用戶端驗證且惡意用戶端連線,則可觸發此問題。(CVE-2022-3786)

- 在 X.509 憑證驗證中可觸發緩衝區滿溢,特別是在名稱限制檢查中。請注意,此問題會在憑證鏈簽章驗證之後發生,且需要 CA 簽署惡意憑證,或是即使無法建構受信任的簽發者路徑,應用程式仍需繼續進行憑證驗證。攻擊者可建構惡意電子郵件地址,造成堆疊中溢出四個受攻擊者控制的位元組。此緩衝區溢位問題可能會導致當機 (造成拒絕服務攻擊),或觸發遠端程式碼執行攻擊。許多平台已實作堆疊溢位保護措施,可減輕遠端程式碼執行的風險。可根據任何指定平台/編譯器的堆疊配置進一步降低風險。 CVE-2022-3602 的預先公告將此問題描述為「重大」。根據上述一些減輕風險的因素進行進一步分析後,已將此問題降級為「高風險」。仍建議使用者盡快升級至新版本。在 TLS 用戶端中,藉由連線至惡意伺服器即可觸發此問題。
在 TLS 伺服器中,如果伺服器要求用戶端驗證且惡意用戶端連線,則可觸發此問題。(CVE-2022-3602)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 OpenSSL 3.0.7 或更新版本。

另請參閱

https://www.openssl.org/news/secadv/20221101.txt

http://www.nessus.org/u?a438010d

Plugin 詳細資訊

嚴重性: High

ID: 166773

檔案名稱: openssl_3_0_7.nasl

版本: 1.8

類型: remote

系列: Web Servers

已發布: 2022/11/1

已更新: 2022/12/15

風險資訊

VPR

風險因素: High

分數: 7.1

CVSS v2

風險因素: High

基本分數: 7.8

時間分數: 5.8

媒介: AV:N/AC:L/Au:N/C:N/I:N/A:C

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-3786

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:openssl:openssl

必要的 KB 項目: openssl/port

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/11/1

弱點發布日期: 2022/11/1

參考資訊

CVE: CVE-2022-3602, CVE-2022-3786

IAVA: 2022-A-0452-S

CEA-ID: CEA-2022-0036