Samba 4.0.x < 4.15.11 / 4.16.x < 4.16.6 / 4.17.x < 4.17.2 緩衝區溢位

medium Nessus Plugin ID 166770

Synopsis

遠端 Samba 伺服器受到堆積型緩衝區溢位弱點影響

描述

Samba 4.0 之後使用 Heimdal Kerberos 編譯的所有版本都存在堆積型緩衝區溢位條件。
在 Heimdal 的 GSSAPI 程式庫常式 unwrap_des() 和 unwrap_des3() (Samba 4.11 及更舊版本為 DES,較新版本為 Triple-DES) 中,若在執行長度受限的寫入時隨附惡意小封包,malloc() 配置的記憶體會發生堆積型緩衝區溢位。以 MIT Kerberos 編譯 Samba 並使用旗標「--with-system-mitkrb5」,即可避免此問題。經驗證的遠端攻擊者可利用此缺陷,透過網路引致拒絕服務條件或執行任意程式碼。(CVE-2022-3437)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 Samba 4.15.11、4.16.6、4.17.2 或更新版本,或是套用供應商提供的因應措施。

另請參閱

https://www.samba.org/samba/security/CVE-2022-3437.html

Plugin 詳細資訊

嚴重性: Medium

ID: 166770

檔案名稱: samba_cve_2022-3437.nasl

版本: 1.4

類型: remote

系列: Misc.

已發布: 2022/11/1

已更新: 2023/1/23

組態: 啟用 Paranoid 模式

風險資訊

VPR

風險因素: Medium

分數: 5.1

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5

媒介: AV:N/AC:L/Au:S/C:N/I:N/A:C

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-3437

CVSS v3

風險因素: Medium

基本分數: 6.5

時間分數: 5.7

媒介: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:samba:samba

必要的 KB 項目: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/10/25

弱點發布日期: 2022/10/28

參考資訊

CVE: CVE-2022-3437

IAVA: 2022-A-0447-S