GLSA-202210-12:Lighttpd:拒絕服務

high Nessus Plugin ID 166723

語系:

描述

遠端主機受到 GLSA-202210-12 中所述的弱點影響 (Lighttpd:拒絕服務)

- 在 lighttpd 1.4.65 中,如果收到無效的 HTTP 要求 (websocket 交握),mod_wstunnel 不會初始化處理程式函式指標。這會導致 NULL 指標解除參照問題,進而引致伺服器當機。外部攻擊者可利用此弱點造成拒絕服務情形。(CVE-2022-37797)

- 在 lighttpd 1.4.56 到 1.4.66 版中,gw_backend.c 中的資源洩漏弱點可在用戶端的大量異常 TCP 行為之後導致拒絕服務 (連線插槽耗盡)。它與某些 HTTP/1.1 區塊情況下的 RDHUP 不當處理有關。例如,mod_fastcgi 的使用會受到影響。
1.4.67 版已經修正此問題。(CVE-2022-41556)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

所有 lighttpd 使用者皆應升級至最新版本:

# emerge --sync # emerge --ask --oneshot --verbose >=www-servers/lighttpd-1.4.67

另請參閱

https://security.gentoo.org/glsa/202210-12

https://bugs.gentoo.org/show_bug.cgi?id=869890

Plugin 詳細資訊

嚴重性: High

ID: 166723

檔案名稱: gentoo_GLSA-202210-12.nasl

版本: 1.2

類型: local

已發布: 2022/10/31

已更新: 2022/10/31

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-41556

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:gentoo:linux:lighttpd, cpe:/o:gentoo:linux

必要的 KB 項目: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/10/31

弱點發布日期: 2022/9/12

參考資訊

CVE: CVE-2022-37797, CVE-2022-41556