GLSA-202210-13:libgcrypt:多個弱點

high Nessus Plugin ID 166722

語系:

描述

遠端主機受到 GLSA-202210-13 中所述的弱點影響 (Libgcrypt:多個弱點)

- 在 Libgcrypt 1.8.8 之前版本以及 1.9.x 的 1.9.3 之前版本中,因為缺少指數盲法保護,應用程式會不當處理 ElGamal 加密,以解決針對 mpi_powm 的旁路攻擊,並且沒有適當地選擇窗口大小。這會影響 OpenPGP 中 ElGamal 的使用等。(CVE-2021-33560)

- 在 1.9.4 版之前的 Libgcrypt 中,ElGamal 實作允許純文字復原,這是因為在兩個密碼編譯程式庫之間互動期間,由接收者的公開金鑰所定義的特定危險質數組合、由接收者的公開金鑰所定義的產生器,以及傳送者的暫時指數都可以導致針對 OpenPGP 的跨組態攻擊。(CVE-2021-40528)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

所有 libgcrypt 使用者皆應升級至最新版本:

# emerge --sync # emerge --ask --oneshot --verbose >=dev-libs/libgcrypt-1.9.4

另請參閱

https://security.gentoo.org/glsa/202210-13

https://bugs.gentoo.org/show_bug.cgi?id=766213

https://bugs.gentoo.org/show_bug.cgi?id=795480

https://bugs.gentoo.org/show_bug.cgi?id=811900

Plugin 詳細資訊

嚴重性: High

ID: 166722

檔案名稱: gentoo_GLSA-202210-13.nasl

版本: 1.2

類型: local

已發布: 2022/10/31

已更新: 2022/10/31

風險資訊

VPR

風險因素: Medium

分數: 5.1

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

時間媒介: CVSS2#E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-33560

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: cpe:2.3:o:gentoo:linux:*:*:*:*:*:*:*:*, p-cpe:2.3:a:gentoo:linux:libgcrypt:*:*:*:*:*:*:*

必要的 KB 項目: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/10/31

弱點發布日期: 2021/6/8

參考資訊

CVE: CVE-2021-33560, CVE-2021-40528