Apache Commons Text 1.5.x < 1.10.0 遠端程式碼執行 (CVE-2022-42889)

critical Nessus Plugin ID 166250

Synopsis

遠端主機上安裝的套件受到遠端程式碼執行弱點影響。

描述

遠端主機上的 Apache Commons Text 版本為 1.5.x < 1.10.0。因此,它受到遠端程式碼執行弱點影響,這是因為 StringSubstitutor 預設內插器中的指令碼評估不安全。

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 Apache Commons Text 1.10.0 或更新版本。

另請參閱

http://www.nessus.org/u?06368034

https://www.openwall.com/lists/oss-security/2022/10/13/4

Plugin 詳細資訊

嚴重性: Critical

ID: 166250

檔案名稱: apache_commons_text_1_10_0.nasl

版本: 1.2

類型: local

代理程式: windows, macosx, unix

系列: Misc.

已發布: 2022/10/19

已更新: 2022/10/20

組態: 啟用徹底檢查

支持的傳感器: Nessus Agent

風險資訊

VPR

風險因素: Critical

分數: 9.5

CVSS v2

風險因素: Critical

基本分數: 10

時間分數: 7.4

媒介: AV:N/AC:L/Au:N/C:C/I:C/A:C

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-42889

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:commons_text

必要的 KB 項目: installed_sw/Apache Commons Text

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/10/12

弱點發布日期: 2022/10/12

參考資訊

CVE: CVE-2022-42889