GLSA-202210-01:Open Asset Import Library (assimp):多個弱點

medium Nessus Plugin ID 166168

語系:

描述

遠端主機受到 GLSA-202210-01 中所述的弱點影響 (Open Asset Import Library (assimp):
多個弱點)

- Open Asset Import Library (又稱 assimp) 5.1.0 和 5.1.1 的 _m3d_safestr 中存在堆積型緩衝區溢位弱點 (從 m3d_load 和 Assimp: : M3DWrapper: : M3DWrapper 呼叫)。(CVE-2021-45948)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

所有 Open Asset Import Library 使用者皆應升級至最新版本:

# emerge --sync # emerge --ask --oneshot --verbose >=media-libs/assimp-5.2.2

另請參閱

https://security.gentoo.org/glsa/202210-01

https://bugs.gentoo.org/show_bug.cgi?id=830374

Plugin 詳細資訊

嚴重性: Medium

ID: 166168

檔案名稱: gentoo_GLSA-202210-01.nasl

版本: 1.2

類型: local

已發布: 2022/10/17

已更新: 2022/10/17

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

時間媒介: CVSS2#E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-45948

CVSS v3

風險因素: Medium

基本分數: 5.5

時間分數: 4.8

媒介: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: cpe:2.3:o:gentoo:linux:*:*:*:*:*:*:*:*, p-cpe:2.3:a:gentoo:linux:assimp:*:*:*:*:*:*:*

必要的 KB 項目: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/10/16

弱點發布日期: 2022/1/1

參考資訊

CVE: CVE-2021-45948