Drupal 9.3.x < 9.3.22 / 9.4.x < 9.4.7 Drupal 弱點 (SA-CORE-2022-016)

high Nessus Plugin ID 165520

Synopsis

遠端 Web 伺服器上執行的 PHP 應用程式受到一個弱點影響。

描述

根據其自我報告的版本號碼,遠端網頁伺服器上執行的 Drupal 執行個體是早於 9.3.22 的 9.3.x 版或早於 9.4.7 的 9.4.x 版。因此,它受到一個弱點影響。

- Twig 是一種適用於 PHP 的範本語言。當檔案系統載入器載入由使用者輸入名稱的範本時,低於 1.44.7 的1.x 版、低於 2.15.3 的 2.x 版低於 3.4.3 的 3.x 版會遇到問題。使用「@somewhere/../some.file」之類的命名空間時,使用者可以使用「source」或「include」陳述式從範本目錄外部讀取任意檔案。在這種情況下,可以繞過驗證。
1.44.7、2.15.3 和 3.4.3 版包含針對此類範本名稱驗證的修正。除了升級外,目前沒有其他已知的因應措施。(CVE-2022-39261)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 Drupal 9.3.22 / 9.4.7 版或更新版本。

另請參閱

https://www.drupal.org/sa-core-2022-016

http://www.nessus.org/u?3f6ab4df

https://twig.symfony.com/

https://www.drupal.org/project/drupal/releases/9.3.22

https://www.drupal.org/project/drupal/releases/9.4.7

https://www.drupal.org/psa-2021-06-29

Plugin 詳細資訊

嚴重性: High

ID: 165520

檔案名稱: drupal_9_4_7.nasl

版本: 1.6

類型: remote

系列: CGI abuses

已發布: 2022/9/28

已更新: 2023/1/27

組態: 啟用 Paranoid 模式, 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: High

基本分數: 7.8

時間分數: 5.8

媒介: AV:N/AC:L/Au:N/C:C/I:N/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-39261

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:drupal:drupal

必要的 KB 項目: installed_sw/Drupal, Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/9/28

弱點發布日期: 2022/9/28

參考資訊

CVE: CVE-2022-39261

IAVA: 2022-A-0449-S