Debian DLA-3101-1:libxslt - LTS 安全性更新

high Nessus Plugin ID 164935

Synopsis

遠端 Debian 主機上缺少一個或多個安全性更新。

描述

遠端 Debian 10 主機上安裝的多個套件受到 dla-3101 公告中提及的多個弱點影響。

- 在 libxslt 1.1.33 之前版本的 xsltNumberFormatGetMultipleLevel 中存在類型混淆弱點,攻擊者可能藉此透過特製的 XML 資料造成堆積損毀。(CVE-2019-5815)

- Google Chrome 91.0.4472.164 更舊版本的 Blink XSLT 中存在釋放後使用問題,此弱點允許遠端攻擊者可能透過建構的 HTML 頁面,惡意引致堆積損毀。(CVE-2021-30560)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級 libxslt 套件。

針對 Debian 10 buster,已在 1.1.32-2.2~deb10u2 版本中修正這些問題。

另請參閱

https://security-tracker.debian.org/tracker/source-package/libxslt

https://www.debian.org/lts/security/2022/dla-3101

https://security-tracker.debian.org/tracker/CVE-2019-5815

https://security-tracker.debian.org/tracker/CVE-2021-30560

https://packages.debian.org/source/buster/libxslt

Plugin 詳細資訊

嚴重性: High

ID: 164935

檔案名稱: debian_DLA-3101.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2022/9/10

已更新: 2022/9/10

支持的傳感器: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-30560

CVSS v3

風險因素: High

基本分數: 8.8

時間分數: 7.7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:libxslt1-dev, p-cpe:/a:debian:debian_linux:libxslt1.1, p-cpe:/a:debian:debian_linux:python-libxslt1, p-cpe:/a:debian:debian_linux:python-libxslt1-dbg, p-cpe:/a:debian:debian_linux:xsltproc, cpe:/o:debian:debian_linux:10.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/9/9

弱點發布日期: 2019/4/23

參考資訊

CVE: CVE-2019-5815, CVE-2021-30560