Wireshark 3.4.x < 3.4.16 一個弱點 (macOS)

high Nessus Plugin ID 164837

Synopsis

遠端 macOS / Mac OS X 主機上安裝的一個應用程式受到一個弱點影響。

描述

遠端 macOS / Mac OS X 主機上安裝的 Wireshark 版本比 3.4.16 舊。因此,它受到 wireshark-3.4.16 公告中提及的一個弱點影響。

- F5 Ethernet Trailer 解剖器可進入無限迴圈。藉由將格式錯誤的封包插入連線,或引誘使用者讀取格式錯誤的封包追蹤檔案,可能造成 Wireshark 過度消耗 CPU 資源。(wireshark-bug-18307)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級版本至 Wireshark 3.4.16 或更新版本。

另請參閱

https://www.wireshark.org/docs/relnotes/wireshark-3.4.16.html

https://gitlab.com/wireshark/wireshark/-/issues/18307

https://www.wireshark.org/security/wnpa-sec-2022-06

Plugin 詳細資訊

嚴重性: High

ID: 164837

檔案名稱: macosx_wireshark_3_4_16.nasl

版本: 1.3

類型: local

代理程式: macosx

已發布: 2022/9/7

已更新: 2022/9/23

支持的傳感器: Nessus Agent

弱點資訊

CPE: cpe:/a:wireshark:wireshark

必要的 KB 項目: installed_sw/Wireshark, Host/MacOSX/Version, Host/local_checks_enabled

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/9/7

弱點發布日期: 2022/9/7

參考資訊

IAVB: 2022-B-0035