IBM WebSphere Application Server Liberty 17.0.0.3 < 22.0.0.8 (6602039)

high Nessus Plugin ID 164809

Synopsis

遠端 Web 應用程式伺服器受到一個弱點影響。

描述

遠端主機上執行的 IBM WebSphere Application Server Liberty 版本受到 6602039 公告中提及的一個弱點影響。

- 在 Eclipse Paho Java 用戶端程式庫 1.2.0 版中,當連線至使用 TLS 並設定主機名稱驗證程式的 MQTT 伺服器時,程式不會檢查該驗證的結果。因此,一個 MQTT 伺服器可模擬另一個 MQTT 伺服器,並向用戶端程式庫提供錯誤資訊。(CVE-2019-11777)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

更新至 IBM WebSphere Application Server 22.0.0.8 或更新版本。或者,升級版本至過渡期修正所需的最低 Fix Pack 等級,然後套用過渡期修正 PH45750。

另請參閱

https://www.ibm.com/support/pages/node/6602039

Plugin 詳細資訊

嚴重性: High

ID: 164809

檔案名稱: websphere_liberty_6602039.nasl

版本: 1.2

類型: remote

代理程式: windows, macosx, unix

系列: Web Servers

已發布: 2022/9/7

已更新: 2022/9/7

支持的傳感器: Nessus Agent

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

時間媒介: CVSS2#E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2019-11777

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: cpe:2.3:a:ibm:websphere_application_server:*:*:*:*:*:*:*:*

必要的 KB 項目: installed_sw/IBM WebSphere Application Server

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/7/7

弱點發布日期: 2019/9/11

參考資訊

CVE: CVE-2019-11777