Debian DSA-5208-1:epiphany-browser - 安全性更新

high Nessus Plugin ID 164169

Synopsis

遠端 Debian 主機缺少與安全性相關的更新。

描述

遠端 Debian 11 主機上安裝的多個套件受 dsa-5208 公告中提及的一個弱點影響。

- 在 GNOME Epiphany 41.4 之前版本和 42.x 之前的 42.2 版中,HTML 文件可透過長頁面標題觸發用戶端緩衝區溢位 (在 UI 處理程序的 ephy_string_shorten 中)。發生此問題的原因在於,未正確考量 UTF-8 省略號字元的位元組數。(CVE-2022-29536)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級 epiphany-browser 套件。

針對穩定的發行版本 (bullseye),已在 3.38.2-1+deb11u3 版本中修正此問題。

另請參閱

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1009959

http://www.nessus.org/u?699d342c

https://www.debian.org/security/2022/dsa-5208

https://security-tracker.debian.org/tracker/CVE-2022-29536

https://packages.debian.org/source/bullseye/epiphany-browser

Plugin 詳細資訊

嚴重性: High

ID: 164169

檔案名稱: debian_DSA-5208.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2022/8/17

已更新: 2022/8/17

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-29536

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:epiphany-browser, p-cpe:/a:debian:debian_linux:epiphany-browser-data, cpe:/o:debian:debian_linux:11.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/8/16

弱點發布日期: 2022/4/20

參考資訊

CVE: CVE-2022-29536