Ubuntu 20.04 LTS / 22.04 LTS:GNOME Web 弱點 (USN-5561-1)

medium Nessus Plugin ID 164146

Synopsis

遠端 Ubuntu 主機缺少一個或多個安全性更新。

描述

遠端 Ubuntu 20.04 LTS/22.04 LTS 主機上安裝的套件受到 USN-5561-1 公告中所提及的多個弱點影響。

- 在 GNOME Web (又稱 Epiphany) 40.4 之前版本以及 41.1 之前的 41.x 版中,攻擊者可透過 about: 頁面執行 XSS 攻擊,如 ephy-about: overview 所示,當使用者造訪 XSS 裝載頁面足夠頻繁時, 應用程式會將此頁面加入「最常瀏覽」清單。(CVE-2021-45085)

- 在 GNOME Web (即 Epiphany) 中, 40.441.x ] 之前和 41.1 中可發生 XSS,這是因為伺服器的 supported_filename 在 PDF.js 中用作 pdf_name 值。 (CVE-2021-45086)

- 在 GNOME Web (即 Epiphany) 40.4 之前版本以及 41.1 之前的 41.x 版中,當使用「檢視來源」模式或「閱讀器」模式時,可能會發生 XSS,如頁面標題所示。(CVE-2021-45087)

- 在 GNOME Epiphany 41.4 之前版本和 42.x 之前的 42.2 版中,HTML 文件可透過長頁面標題觸發用戶端緩衝區溢位 (在 UI 處理程序的 ephy_string_shorten 中)。發生此問題的原因在於,未正確考量 UTF-8 省略號字元的位元組數。(CVE-2022-29536)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

更新受影響的 epiphany-browser 和/或 epiphany-browser-data 套件。

另請參閱

https://ubuntu.com/security/notices/USN-5561-1

Plugin 詳細資訊

嚴重性: Medium

ID: 164146

檔案名稱: ubuntu_USN-5561-1.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2022/8/16

已更新: 2022/8/16

支持的傳感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: AV:N/AC:M/Au:N/C:N/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-45087

CVSS v3

風險因素: Medium

基本分數: 6.1

時間分數: 5.3

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:22.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:epiphany-browser, p-cpe:/a:canonical:ubuntu_linux:epiphany-browser-data

必要的 KB 項目: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/8/10

弱點發布日期: 2021/12/16

參考資訊

CVE: CVE-2021-45085, CVE-2021-45086, CVE-2021-45087, CVE-2022-29536

USN: 5561-1