Ubuntu 20.04 LTS / 22.04 LTS:WebKitGTK 弱點 (USN-5568-1)

high Nessus Plugin ID 164124

Synopsis

遠端 Ubuntu 主機缺少一個或多個安全性更新。

描述

遠端 Ubuntu 20.04 LTS/22.04 LTS 主機上安裝的套件受到 USN-5568-1 公告中所提及的多個弱點影響。

- Google Chrome 103.0.5060.114 之前版本的 WebRTC 中存在堆積型緩衝區溢位弱點,此弱點允許遠端攻擊者透過建構的 HTML 頁面,惡意引致堆積損毀。(CVE-2022-2294)

- 已透過改進輸入驗證解決超出邊界寫入問題。(CVE-2022-32792)

- 已透過改進 UI 處理解決此問題。(CVE-2022-32816)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

更新受影響的套件。

另請參閱

https://ubuntu.com/security/notices/USN-5568-1

Plugin 詳細資訊

嚴重性: High

ID: 164124

檔案名稱: ubuntu_USN-5568-1.nasl

版本: 1.3

類型: local

代理程式: unix

已發布: 2022/8/15

已更新: 2022/8/29

支持的傳感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

風險資訊

VPR

風險因素: Critical

分數: 9.9

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5.9

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:H/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-2294

CVSS v3

風險因素: High

基本分數: 8.8

時間分數: 8.4

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

時間媒介: E:H/RL:O/RC:C

弱點資訊

CPE: cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:22.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:gir1.2-javascriptcoregtk-4.0, p-cpe:/a:canonical:ubuntu_linux:gir1.2-javascriptcoregtk-4.1, p-cpe:/a:canonical:ubuntu_linux:gir1.2-webkit2-4.0, p-cpe:/a:canonical:ubuntu_linux:gir1.2-webkit2-4.1, p-cpe:/a:canonical:ubuntu_linux:libjavascriptcoregtk-4.0-18, p-cpe:/a:canonical:ubuntu_linux:libjavascriptcoregtk-4.0-bin, p-cpe:/a:canonical:ubuntu_linux:libjavascriptcoregtk-4.0-dev, p-cpe:/a:canonical:ubuntu_linux:libjavascriptcoregtk-4.1-0, p-cpe:/a:canonical:ubuntu_linux:libjavascriptcoregtk-4.1-dev, p-cpe:/a:canonical:ubuntu_linux:libwebkit2gtk-4.0-37, p-cpe:/a:canonical:ubuntu_linux:libwebkit2gtk-4.0-37-gtk2, p-cpe:/a:canonical:ubuntu_linux:libwebkit2gtk-4.0-dev, p-cpe:/a:canonical:ubuntu_linux:libwebkit2gtk-4.1-0, p-cpe:/a:canonical:ubuntu_linux:libwebkit2gtk-4.1-dev, p-cpe:/a:canonical:ubuntu_linux:webkit2gtk-driver

必要的 KB 項目: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2022/8/15

弱點發布日期: 2022/7/4

CISA 已知利用日期: 2022/9/15

參考資訊

CVE: CVE-2022-2294, CVE-2022-32792, CVE-2022-32816

USN: 5568-1