GLSA-202208-26:libarchive:多個弱點

critical Nessus Plugin ID 164119

語系:

描述

遠端主機受到 GLSA-202208-26 中所述的弱點影響 (libarchive:多個弱點)

- libarchive 3.4.1 版至 3.5.1 版的 copy_string (從 do_uncompress_block 和 process_block 呼叫) 中有一個釋放後使用問題。(CVE-2021-36976)

- 已發現 Libarchive v3.6.0 含有一個透過 zipx_lzma_alone_init 元件發生的越界讀取。
(CVE-2022-26280)

- ** 拒絕 ** 請勿使用此候選版本編號。ConsultIDs:CVE-2022-26280。原因:此候選編號是 CVE-2022-26280 的複本。注意:所有 CVE 使用者都應該參照 CVE-2022-26280 而非此候選編號。已移除此候選版本中的所有參照和描述,以防止意外使用。(CVE-2022-28066)

- libarchive:在擷取封存期間變更檔案的模式、時間、ACL 和旗標時,未正確遵循符號連結 (CVE-2021-31566)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

所有 libarchive 使用者皆應升級至最新版本:

# emerge --sync # emerge --ask --oneshot --verbose >=app-arch/libarchive-3.6.1

另請參閱

https://security.gentoo.org/glsa/202208-26

https://bugs.gentoo.org/show_bug.cgi?id=803128

https://bugs.gentoo.org/show_bug.cgi?id=836352

https://bugs.gentoo.org/show_bug.cgi?id=837266

Plugin 詳細資訊

嚴重性: Critical

ID: 164119

檔案名稱: gentoo_GLSA-202208-26.nasl

版本: 1.2

類型: local

已發布: 2022/8/15

已更新: 2022/8/15

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Medium

基本分數: 6.4

時間分數: 4.7

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-26280

CVSS v3

風險因素: Critical

基本分數: 9.1

時間分數: 7.9

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:gentoo:linux:libarchive, cpe:/o:gentoo:linux

必要的 KB 項目: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/8/14

弱點發布日期: 2021/7/20

參考資訊

CVE: CVE-2021-31566, CVE-2021-36976, CVE-2022-26280, CVE-2022-28066