GLSA-202208-21:libebml:堆積型緩衝區溢位弱點

medium Nessus Plugin ID 164118

語系:

描述

遠端主機受到 GLSA-202208-21 中所述的弱點影響 (libebml:堆積型緩衝區溢位弱點)

- 在 1.4.2 之前的 libebml 中發現一個瑕疵。libebml 中 EbmlString: : ReadData 和 EbmlUnicodeString: : ReadData 的實作中存在堆積溢位錯誤。(CVE-2021-3405)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

32 位元架構上的 libebml 使用者應升級至最新版本:

# emerge --sync # emerge --ask --oneshot --verbose >=dev-libs/libebml-1.4.2

另請參閱

https://security.gentoo.org/glsa/202208-21

https://bugs.gentoo.org/show_bug.cgi?id=772272

Plugin 詳細資訊

嚴重性: Medium

ID: 164118

檔案名稱: gentoo_GLSA-202208-21.nasl

版本: 1.2

類型: local

已發布: 2022/8/15

已更新: 2022/8/15

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: AV:N/AC:M/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-3405

CVSS v3

風險因素: Medium

基本分數: 6.5

時間分數: 5.7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:gentoo:linux:libebml, cpe:/o:gentoo:linux

必要的 KB 項目: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/8/14

弱點發布日期: 2021/2/23

參考資訊

CVE: CVE-2021-3405