GLSA-202208-22 : xterm: Multiple Vulnerabilities

critical Nessus Plugin ID 164111

語系:

描述

遠端主機受到 GLSA-202208-22 中所述的弱點影響 (xterm:多個弱點)

- xterm 修補程式 #366 之前版本允許遠端攻擊者透過特製的 UTF-8 組合字元序列造成拒絕服務 (分割錯誤)。(CVE-2021-27135)

- xterm Patch 370 及更早版本啟用 Sixel 支援時,允許攻擊者透過建構的文字,在 graphics_sixel.c 的 set_sixel 中觸發緩衝區溢位弱點。(CVE-2022-24130)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

所有 xterm 使用者皆應升級至最新版本:

# emerge --sync # emerge --ask --oneshot --verbose >=x11-terms/xterm-371

另請參閱

https://security.gentoo.org/glsa/202208-22

https://bugs.gentoo.org/show_bug.cgi?id=769839

https://bugs.gentoo.org/show_bug.cgi?id=832409

Plugin 詳細資訊

嚴重性: Critical

ID: 164111

檔案名稱: gentoo_GLSA-202208-22.nasl

版本: 1.2

類型: local

已發布: 2022/8/15

已更新: 2022/8/15

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: CVSS2#E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-27135

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: cpe:2.3:o:gentoo:linux:*:*:*:*:*:*:*:*, p-cpe:2.3:a:gentoo:linux:xterm:*:*:*:*:*:*:*

必要的 KB 項目: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/8/14

弱點發布日期: 2021/2/10

參考資訊

CVE: CVE-2021-27135, CVE-2022-24130