GLSA-202208-29:Nokogiri:多個弱點

high Nessus Plugin ID 164110

語系:

描述

遠端主機受到 GLSA-202208-29 中所述的弱點影響 (Nokogiri:多個弱點)

- Nokogiri 是爲 HTML、XML、SAX 和 Reader 剖析器提供 XPath 和 CSS 選擇器支援的 Rubygem。在 1.11.0.rc4 版之前的 Nokogiri 中發現 XXE 弱點。程式依預設信任使用 Nokogiri: : XML: : Schema 剖析的 XML Schema,這允許攻擊者透過網路存取外部資源,進而可能發動 XXE 或 SSRF 攻擊。此行為與 Nokogiri 維護者遵循的安全性原則相反,該原則會依預設盡可能將所有輸入視為不受信任的輸入。此問題已在 Nokogiri 1.11.0.rc4 版中修正。(CVE-2020-26247)

- Nokogiri 是適用於 Ruby 的開放原始碼 XML 和 HTML 程式庫。Nokogiri 1.13.4 版本中包含一個低效的規則運算式,當嘗試在 HTML 文件中偵測編碼時,該運算式容易受到過度回溯影響。建議使用者升級到 Nokogiri 1.13.4 及更高版本。目前沒有任何因應措施可解決此問題。(CVE-2022-24836)

- Nokogiri 是適用於 Ruby 的開放原始碼 XML 和 HTML 程式庫。 1.13.6 之前版本的 Nokogiri 未對 XML 和 HTML4 SAX 剖析器的所有輸入進行類型檢查,這允許攻擊者透過特製的不受信任的輸入造成非法記憶體存取錯誤 (segfault),或讀取不相關的記憶體。 1.13.6 版包含針對此問題的修補程式。因應措施是呼叫「#to_s」或等同方法,確保不受信任的輸入為「String」。(CVE-2022-29181)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

所有 Nokogiri 使用者皆應升級至最新版本:

# emerge --sync # emerge --ask --oneshot --verbose >=dev-ruby/nokogiri-1.13.6

另請參閱

https://security.gentoo.org/glsa/202208-29

https://bugs.gentoo.org/show_bug.cgi?id=762685

https://bugs.gentoo.org/show_bug.cgi?id=837902

https://bugs.gentoo.org/show_bug.cgi?id=846623

Plugin 詳細資訊

嚴重性: High

ID: 164110

檔案名稱: gentoo_GLSA-202208-29.nasl

版本: 1.2

類型: local

已發布: 2022/8/15

已更新: 2022/8/15

風險資訊

VPR

風險因素: Medium

分數: 4.2

CVSS v2

風險因素: Medium

基本分數: 6.4

時間分數: 4.7

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-29181

CVSS v3

風險因素: High

基本分數: 8.2

時間分數: 7.1

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:gentoo:linux:nokogiri, cpe:/o:gentoo:linux

必要的 KB 項目: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/8/14

弱點發布日期: 2020/12/30

參考資訊

CVE: CVE-2020-26247, CVE-2022-24836, CVE-2022-29181