JQuery UI < 1.13.2 XSS

medium Nessus Plugin ID 163599

Synopsis

遠端 Web 伺服器受到跨網站指令碼弱點的影響。

描述

遠端 Web 伺服器上主控的 JQuery UI 程式庫版本早於 1.13.2。因此,它受到 JQuery UI 中的跨網站指令碼弱點影響,遠端攻擊者可藉此透過處理遭入侵的 checkboxradio Widget 的值,插入任意 Web 指令碼或 HTML。

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 JQuery UI 1.13.2 或更新版本。

另請參閱

https://blog.jqueryui.com/2022/07/jquery-ui-1-13-2-released/

Plugin 詳細資訊

嚴重性: Medium

ID: 163599

檔案名稱: jquery-ui_1_13_2.nasl

版本: 1.2

類型: remote

系列: CGI abuses

已發布: 2022/7/29

已更新: 2022/8/1

組態: 啟用 Paranoid 模式

風險資訊

VPR

風險因素: Low

分數: 3.8

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

時間媒介: CVSS2#E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-31160

CVSS v3

風險因素: Medium

基本分數: 6.1

時間分數: 5.3

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

必要的 KB 項目: Settings/ParanoidReport, installed_sw/jquery_ui

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/7/14

弱點發布日期: 2022/7/14

參考資訊

CVE: CVE-2022-31160

IAVB: 2022-B-0022