Atlassian Confluence < 7.4.17 / 7.5.x < 7.13.7 / 7.14.x < 7.14.3 / 7.15.x < 7.15.2 / 7.16.x < 7.16.4 / 7.17.x < 7.17.4 XSS (CONFSERVER-79476)

critical Nessus Plugin ID 163307

Synopsis

遠端 Atlassian Confluence 主機缺少安全性更新。

描述

遠端主機上安裝的 Atlassian SourceTree 版本低於 < 7.4.17 / 7.5.x < 7.13.7 / 7.14.x < 7.14.3 / 7.15.x < 7.15.2 / 7.16.x < 7.16.4 / 7.17.x < 7.17.4。因此,它受到 CONFSERVER-79476 公告中提及的一個弱點影響。

- Confluence Server 和 Data Center 中的多個 Servlet 篩選器弱點已修正,這些弱點也會影響其他 Atlassian 產品。如需詳細資訊,請參閱 Atlassian 安全公告 |https://confluence.atlassian.com/security/。multiple-products-security-advisory-cve-2022-26136-cve-2022-26137-1141493031.html]. h3。任意 Servlet 篩選器略過 (CVE-2022-26136) 未經驗證的遠端攻擊者可略過第一方和第三方應用程式使用的 Servlet 篩選器。此問題造成的影響視乎各應用程式使用的篩選器及其使用方式而不同。Atlassian 已發佈可修正此弱點根本原因的更新,但尚未詳盡列舉此弱點的所有潛在後果。目前僅確認下列攻擊:{*}驗證繞過{*}。藉由傳送特別建構的 HTTP 要求,可繞過第三方應用程式用來強制驗證的自訂 Servlet 篩選器。未經驗證的遠端攻擊者可利用此弱點繞過第三方應用程式使用的驗證。請注意,Atlassian 已確認可能導致此攻擊,但尚未確定所有受影響應用程式的清單。{*}跨網站指令碼 (XSS){*}。藉由傳送特別建構的 HTTP 要求,可繞過用於驗證合法 Atlassian Gadget 的 Servlet 篩選器,進而可導致 XSS 攻擊。攻擊者可誘騙使用者要求惡意 URL,藉此在使用者的瀏覽器中執行任意 Javascript。h3。其他 Servlet 篩選器叫用 (CVE-2022-26137) 應用程式處理要求或回應時,未經驗證的遠端攻擊者可造成應用程式叫用其他 Servlet 篩選器。Atlassian 已確認並修正已知與此弱點相關的唯一安全性問題:{*}跨來源資源共用 (CORS) 略過{*}。藉由傳送特別建構的 HTTP 要求,可叫用用於回應 CORS 要求的 Servlet 篩選器,進而導致 CORS 略過。攻擊者可誘騙使用者要求惡意 URL,進而使用受害者的權限存取有弱點的應用程式。h3. 受影響的版本:* 版本 < 7.4.17 * 所有 7.5.x 至 7.12.x 版本* 7.13.x < 7.13.7 * 7.14.x < 7.14.3 * 7.15.x < 7.15.2 * 7.16.x < 7.16.4 * 7.17.x < 7.17.4 * 7.18.0 h3。修正的版本:* 7.4.x >= 7.4.17 ([LTS|https://confluence.atlassian.com/enterprise/long-term-support-releases-948227420.html]) * 7.13.x >= 7.13.7 ([LTS|https://confluence.atlassian.com/enterprise/long-term-support-releases-948227420.html]) * 7.14.x >= 7.14.3 * 7.15.x >= 7.15.2 * 7.16.x >= 7.16.4 * 7.17.x >= 7.17.4 * 版本 >= 7.18.1 h3。參照 [多個產品安全公告 2022-07-20|https://confluence.atlassian.com/security/multiple-products-security-advisory-cve-2022-26136-cve-2022-26137-1141493031.html] (atlassian-CONFSERVER-79476)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 Atlassian Confluence 7.4.17、7.13.7、7.14.3、7.15.2、7.16.4、7.17.4 或更新版本。

另請參閱

https://jira.atlassian.com/browse/CONFSERVER-79476

Plugin 詳細資訊

嚴重性: Critical

ID: 163307

檔案名稱: confluence_confserver-79476.nasl

版本: 1.7

類型: remote

已發布: 2022/7/20

已更新: 2022/10/5

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-26136

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:atlassian:confluence

必要的 KB 項目: installed_sw/confluence

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/7/5

弱點發布日期: 2022/7/5

參考資訊

CVE: CVE-2022-26136

IAVA: 2022-A-0293