GitLab 11.1 < 14.10.5/15.0 < 15.0.4/15.1 < 15.1.1 XSS

medium Nessus Plugin ID 163075

Synopsis

遠端 Web 伺服器上執行的原始程式碼控制應用程式受到開放式重新導向弱點的影響。

描述

根據其自我報告的版本,遠端 Web 伺服器上執行的 GitLab 執行個體是早於 14.10.5 的 11.1 版本、早於 15.0.4 的 15.0 版本或早於 15.1.1 的 15.1 版本。因此,它受到一個開放式重新導向弱點影響,攻擊者可藉此將使用者重新導向至惡意位置。

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 GitLab 14.10.5、15.0.4、15.1.1 或更新版本。

另請參閱

http://www.nessus.org/u?8c545f1d

Plugin 詳細資訊

嚴重性: Medium

ID: 163075

檔案名稱: gitlab_cve-2022-2250.nasl

版本: 1.4

類型: combined

代理程式: unix

系列: CGI abuses

已發布: 2022/7/13

已更新: 2022/8/9

支持的傳感器: Nessus Agent

風險資訊

VPR

風險因素: Low

分數: 3

CVSS v2

風險因素: Medium

基本分數: 5.8

時間分數: 4.3

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-2250

CVSS v3

風險因素: Medium

基本分數: 6.1

時間分數: 5.3

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:gitlab:gitlab

必要的 KB 項目: installed_sw/GitLab

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/6/30

弱點發布日期: 2022/6/30

參考資訊

CVE: CVE-2022-2250

IAVA: 2022-A-0263-S