Apache APISIX Dashboard 2.6 < 2.6.1 Authentication Bypass

medium Nessus Plugin ID 161978

Synopsis

遠端主機上安裝的應用程式缺少供應商提供的安全性更新。

描述

遠端主機上安裝的 Apache APISIX Dashboard 版本為 2.6 的 2.6.1 之前版本。因此會受到一個驗證繞過弱點影響。在 Apache APISIX Dashboard 2.6 版中,我們將接聽主機的預設值變更為 0.0.0.0 ,以便使用者設定外部網路存取權。在 IP 允許清單限制中,使用有風險的函式獲取 IP,這可能會導致惡意使用者繞過網路限制。同時,我們還修正了預設帳戶和密碼。這些因素最終會導致安全性風險問題。此問題已在 APISIX Dashboard 2.6.1 中修正。

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache APISIX Dashboard 2.6.1 或更新版本。

另請參閱

https://lists.apache.org/thread/zyyzycodf2mz9qwgkz3pp8jgmrtmvopo

http://www.nessus.org/u?13dac9a5

Plugin 詳細資訊

嚴重性: Medium

ID: 161978

檔案名稱: apache_apisix_dashboard_2_6_1.nasl

版本: 1.2

類型: remote

系列: Misc.

已發布: 2022/6/9

已更新: 2022/6/13

風險資訊

VPR

風險因素: Low

分數: 1.4

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

時間媒介: CVSS2#E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-33190

CVSS v3

風險因素: Medium

基本分數: 5.3

時間分數: 4.6

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: cpe:2.3:a:apache:apisix_dashboard:*:*:*:*:*:*:*:*

必要的 KB 項目: installed_sw/Apache APISIX Dashboard

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2021/5/27

弱點發布日期: 2021/6/8

參考資訊

CVE: CVE-2021-33190