Apache APISIX < 2.13.0 輸入驗證

critical Nessus Plugin ID 161977

Synopsis

遠端主機上安裝的應用程式缺少供應商提供的安全性更新。

描述

遠端主機上安裝的 Apache APISIX 版本是 2.13.0 之前版本。因此,會受到一個不當輸入驗證弱點影響。解碼包含重複金鑰的 JSON 時,lua-cjson 會選擇上次發生的值作為結果。藉由傳送包含重複金鑰的 JSON,攻擊者可繞過 request-validation 外掛程式中的 body_schema 驗證。符合下列三個條件的系統會受到此攻擊影響:1. 在 request-validation 外掛程式中使用 body_schema 驗證 2. 上游應用程式使用選擇首個發生的值的特殊 JSON 程式庫,例如 jsoniter 或 gojay 3. 上游應用程式不再驗證輸入。

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache APISIX 2.13.0 或更新版本。

另請參閱

https://github.com/apache/apisix/blob/release/2.13/CHANGELOG.md#2130

https://lists.apache.org/thread/03vd2j81krxmpz6xo8p1dl642flpo6fv

Plugin 詳細資訊

嚴重性: Critical

ID: 161977

檔案名稱: apache_apisix_cve-2022-25757.nasl

版本: 1.2

類型: remote

系列: Misc.

已發布: 2022/6/9

已更新: 2022/6/13

組態: 啟用 Paranoid 模式

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-25757

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:apisix

必要的 KB 項目: installed_sw/Apache APISIX, Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/3/28

弱點發布日期: 2022/3/28

參考資訊

CVE: CVE-2022-25757