Apache 2.4.x < 2.4.54 多個弱點

critical Nessus Plugin ID 161948

Synopsis

遠端 Web 伺服器受到多個弱點影響。

描述

遠端主機上安裝的 Apache httpd 版本早於 2.4.54。因此,會受到 2.4.54 公告中所提及的多個弱點影響。

- mod_proxy_ajp 中可能存在要求走私弱點:Apache HTTP Server 的 mod_proxy_ajp 中存在對 HTTP 要求解釋不一致 (「HTTP 要求走私」) 弱點,攻擊者可藉此將要求走私到其轉送要求的 AJP 伺服器。此問題會影響 Apache HTTP Server 2.4、2.4.53 以及更舊版本。致謝:Ricter Z @ 360 Noah Lab (CVE-2022-26377)

- mod_isapi: 中存在超出邊界讀取問題:Windows 主機上的 HTTP Server 2.4.53 和更舊版本存在超出邊界讀取問題,當設定為使用 mod_isapi 模組處理要求時,此弱點可能會造成超出邊界讀取。致謝:Apache HTTP Server 專案組感謝 Ronald Crane (Zippenhop LLC) 報告此問題 (CVE-2022-28330)

- 透過 ap_rwrite() 執行超出邊界讀取:在 Apache HTTP Server 2.4.53 及更早版本中,若攻擊者能夠使用 ap_rwrite() 或 ap_rputs() (例如使用 mod_luas r:puts() 函式 ) 讓伺服器反映超大型輸入,則 ap_rwrite() 函式可能會讀取非預期的記憶體。致謝:Apache HTTP Server 專案組感謝 Ronald Crane (Zippenhop LLC) 報告此問題 (CVE-2022-28614)

- ap_strcmp_match() 中存在超出邊界讀取弱點:在 Apache HTTP Server 2.4.53 和更舊版本中,當應用程式處理超大型輸入緩衝區時,ap_strcmp_match() 中的超出邊界讀取弱點可能會造成應用程式損毀或資訊洩漏。雖然無法將隨伺服器發布的程式碼強制轉換為此類呼叫,但使用 ap_strcmp_match() 的第三方模組或 lua 指令碼可能會受到影響。致謝:Apache HTTP Server 專案組感謝 Ronald Crane (Zippenhop LLC) 報告此問題 (CVE-2022-28615)

- mod_lua r: parsebody 中使用未初始化的值:在 Apache HTTP Server 2.4.53 和更舊版本中,由於對可能的輸入大小沒有預設限制,惡意要求呼叫 parsebody(0) 的 lua 指令碼可能會造成應用程式拒絕服務。致謝:Apache HTTP Server 專案組感謝 Ronald Crane (Zippenhop LLC) 報告此問題 (CVE-2022-29404)

- mod_sed 拒絕服務:如果將 Apache HTTP Server 2.4.53 設定為在 mod_sed 的輸入可能非常大的環境中使用 mod_sed 進行轉換,則 mod_sed 可能會進行超大記憶體配置並觸發中止。致謝:此問題由 JFrog 安全性研究團隊的 Brian Moussalli 發現 (CVE-2022-30522)

- 使用 websockets 的 mod_lua 中存在資訊洩漏弱點:Apache HTTP Server 2.4.53 及更舊版本可能會向呼叫 r: wsread() 的應用程式傳回指向超出為緩衝區配置的儲存區結尾的長度。
致謝:Apache HTTP Server 專案組感謝 Ronald Crane (Zippenhop LLC) 報告此問題 (CVE-2022-30556)

- 在 mod_proxy 中,X-Forwarded-For 被逐跳機制丟棄。:Apache HTTP Server 2.4.53 及更早版本可能不會根據用戶端的 Connection 標頭逐跳機制將 X-Forwarded-* 標頭傳送至原始伺服器。攻擊者可利用此問題繞過原始伺服器/應用程式上的 IP 型驗證。
致謝:Apache HTTP Server 專案組感謝 Gaetan Ferry (Synacktiv) 報告此問題 (CVE-2022-31813)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級至 Apache 2.4.54 或更新版本。

另請參閱

https://httpd.apache.org/security/vulnerabilities_24.html

Plugin 詳細資訊

嚴重性: Critical

ID: 161948

檔案名稱: apache_2_4_54.nasl

版本: 1.7

類型: combined

代理程式: windows, macosx, unix

系列: Web Servers

已發布: 2022/6/8

已更新: 2023/1/19

支持的傳感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

風險資訊

VPR

風險因素: High

分數: 7.4

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-31813

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:httpd, cpe:/a:apache:http_server

必要的 KB 項目: installed_sw/Apache

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/6/8

弱點發布日期: 2022/3/2

參考資訊

CVE: CVE-2022-26377, CVE-2022-28330, CVE-2022-28614, CVE-2022-28615, CVE-2022-29404, CVE-2022-30522, CVE-2022-30556, CVE-2022-31813

IAVA: 2022-A-0230-S