Apache 2.4.x < 2.4.52 mod_lua 緩衝區溢位弱點

critical Nessus Plugin ID 161454

Synopsis

遠端 Web 伺服器受到緩衝區溢位弱點的影響。

描述

遠端主機上安裝的 Apache httpd 版本早於 2.4.52。因此,它在處理多部分內容時,會受到與 mod_lua 相關的缺陷影響。特製的要求內文可造成 mod_lua multipart 剖析器 (從 Lua 指令碼呼叫的 r: parsebody() ) 中發生緩衝區溢位。Apache httpd 團隊尚未發現利用該弱點的情況,不過攻擊者可能會自行建構弱點。

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 Apache 2.4.52 或更新版本。

Plugin 詳細資訊

嚴重性: Critical

ID: 161454

檔案名稱: apache_2_4_52_CVE-2021-44790.nasl

版本: 1.4

類型: combined

代理程式: windows, macosx, unix

系列: Web Servers

已發布: 2022/5/24

已更新: 2022/5/26

組態: 啟用徹底檢查

支持的傳感器: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

風險資訊

VPR

風險因素: High

分數: 8.4

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-44790

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:httpd, cpe:/a:apache:http_server

必要的 KB 項目: installed_sw/Apache

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2021/12/20

弱點發布日期: 2021/11/18

參考資訊

CVE: CVE-2021-44790

IAVA: 2021-A-0604-S