Microsoft .NET Core 安全性更新 (2022 年 5 月)

high Nessus Plugin ID 161167

Synopsis

遠端主機上安裝的 Microsoft .NET Core 受到多個弱點影響。

描述

遠端主機上安裝的 Microsoft .NET Core 缺少安全性更新。因此,其會受到多個拒絕服務弱點影響:

- 惡意用戶端可透過 HttpClient 配置過量記憶體造成拒絕服務的弱點。(CVE-2022-23267)

- 惡意用戶端可操控 Cookie 並造成拒絕服務的弱點。(CVE-2022-29117)

- 惡意用戶端可在系統剖析 HTML 表單時造成拒絕服務的弱點。(CVE-2022-29145)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

更新至 .NET Core Runtime 3.1.25、5.0.17 或 6.0.5。

另請參閱

https://dotnet.microsoft.com/download/dotnet/3.1

https://dotnet.microsoft.com/download/dotnet/5.0

https://dotnet.microsoft.com/download/dotnet/6.0

https://github.com/dotnet/announcements/issues/219

http://www.nessus.org/u?3b99f604

http://www.nessus.org/u?b1b0aff4

http://www.nessus.org/u?39d07c32

Plugin 詳細資訊

嚴重性: High

ID: 161167

檔案名稱: smb_nt_ms22_may_dotnet_core.nasl

版本: 1.7

類型: local

系列: Misc.

已發布: 2022/5/13

已更新: 2022/6/20

支持的傳感器: Frictionless Assessment Agent

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-23267

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

CVSS 評分資料來源: CVE-2022-29145

弱點資訊

CPE: cpe:/a:microsoft:.net_core

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/5/10

弱點發布日期: 2022/5/10

參考資訊

CVE: CVE-2022-23267, CVE-2022-29117, CVE-2022-29145

IAVA: 2022-A-0201-S