IBM Java 7.0 < 7.0.10.45 / 7.1 < 7.1.4.45 / 8.0 < 8.0.5.35 多個弱點

high Nessus Plugin ID 160342

Synopsis

IBM Java 受到多個弱點影響。

描述

遠端主機上安裝的 IBM Java 版本為 7.0 < 7.0.10.45 / 7.1 < 7.1.4.45 / 8.0 < 8.0.5.35。因此,其會受到 2019 年 4 月 16 日 Oracle CPU 公告中提及的多個弱點影響。

Oracle Java SE 的 Java SE、Java SE Embedded 元件中存在弱點 (子元件:程式庫)。
受影響的支援版本是 Java SE:7u211、8u202、11.0.2 和 12;Java SE Embedded:8u201。
此弱點較易攻擊,能夠透過多個通訊協定存取網路的未經驗證攻擊者可藉此入侵 Java SE、Java SE Embedded。若成功攻擊此弱點,可能導致未經授權即可造成 Java SE、Java SE Embedded 懸置或經常重複性當機 (完全 DOS)。注意:此弱點僅可透過以下方式進行利用:提供資料給指定元件中的 API,而不使用未受信任的 Java Web Start 應用程式或是未受信任的 Java Applet,如透過 Web 服務。(CVE-2019-2602)

Oracle Java SE 的 Java SE、Java SE Embedded 元件中存在弱點 (子元件:RMI)。受影響的支援版本是 Java SE:7u211、8u202、11.0.2 和 12;Java SE Embedded:8u201。攻擊此弱點具有難度,能夠透過多個通訊協定存取網路的未經驗證攻擊者可利用此弱點入侵 Java SE、Java SE Embedded。成功攻擊此弱點可導致未經授權地建立、刪除或修改重要資料或所有可供存取之 Java SE、Java SE Embedded 資料的存取權。注意:此弱點適用於 Java 部署,通常是在執行沙箱化 Java Web Start 應用程式或沙箱化 Java Applet (在 Java SE 8 中) 的用戶端中,這種部署會載入並執行不受信任的程式碼 (例如,來自網際網路的程式碼),並依賴 Java 沙箱獲得安全性。使用指定之元件中的 API 也可以惡意利用此弱點,例如,透過提供資料給 API 的 Web 服務。(CVE-2019-2684)

- Oracle Java SE 的 Java SE 元件中有一個弱點 (子元件:2D)。受影響的支援版本是 Java SE:7u211 和 8u202。難以惡意利用的弱點允許具有網路存取權的未經驗證攻擊者透過多個通訊協定入侵 Java SE。如果成功地攻擊此弱點,可能造成接管 Java SE 的後果。注意:此弱點適用於 Java 部署,通常是在執行沙箱化 Java Web Start 應用程式或沙箱化 Java Applet (在 Java SE 8 中) 的用戶端中,這種部署會載入並執行不受信任的程式碼 (例如,來自網際網路的程式碼),並依賴 Java 沙箱獲得安全性。此弱點不適用於僅載入並執行受信任程式碼 (例如,系統管理員安裝的程式碼) 的 Java 部署,且通常存在於伺服器中。(CVE-2019-2697、CVE-2019-2698)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

按照 2019 年 4 月 16 日 Oracle CPU 公告套用適當的修補程式。

另請參閱

http://www-01.ibm.com/support/docview.wss?uid=swg1IJ15688

http://www-01.ibm.com/support/docview.wss?uid=swg1IJ15689

http://www-01.ibm.com/support/docview.wss?uid=swg1IJ15690

http://www-01.ibm.com/support/docview.wss?uid=swg1IJ15691

http://www.nessus.org/u?dabedffd

Plugin 詳細資訊

嚴重性: High

ID: 160342

檔案名稱: ibm_java_2019_04_16.nasl

版本: 1.3

類型: local

代理程式: windows, macosx, unix

系列: Misc.

已發布: 2022/4/29

已更新: 2022/5/2

組態: 啟用徹底檢查

支持的傳感器: Nessus Agent

風險資訊

VPR

風險因素: High

分數: 7.4

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5.3

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:POC/RL:OF/RC:C

CVSS 評分資料來源: CVE-2019-2698

CVSS v3

風險因素: High

基本分數: 8.1

時間分數: 7.3

媒介: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:ibm:java

必要的 KB 項目: installed_sw/Java

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2019/4/16

弱點發布日期: 2019/4/16

參考資訊

CVE: CVE-2019-2602, CVE-2019-2684, CVE-2019-2697, CVE-2019-2698

IAVA: 2019-A-0118-S