IBM Java 7.0 < 7.0.10.45 / 7.1 < 7.1.4.45 / 8.0 < 8.0.5.35

high Nessus Plugin ID 160341

Synopsis

IBM Java 受到一個弱點影響。

描述

遠端主機上安裝的 IBM Java 版本為 7.0 < 7.0.10.45 / 7.1 < 7.1.4.45 / 8.0 < 8.0.5.35。因此,其會受到 2019 年 4 月 IBM 安全性更新公告中提及的一個弱點影響。

- 在 Eclipse OpenJ9 0.14.0 之前版本中,Java 位元組程式碼驗證程式錯誤地允許在超出位元組程式碼陣列結尾處執行某種方法,進而造成當機。Eclipse OpenJ9 v0.14.0 可正確偵測此情況並拒絕類別載入嘗試。(CVE-2019-10245)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

按照 2019 年 4 月 IBM 安全性更新公告套用適當的修補程式。

另請參閱

http://www-01.ibm.com/support/docview.wss?uid=swg1IJ15692

http://www.nessus.org/u?7bbabe18

Plugin 詳細資訊

嚴重性: High

ID: 160341

檔案名稱: ibm_java_2019_04_01.nasl

版本: 1.2

類型: local

代理程式: windows, macosx, unix

系列: Misc.

已發布: 2022/4/29

已更新: 2022/4/29

組態: 啟用徹底檢查

支持的傳感器: Nessus Agent

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

時間媒介: CVSS2#E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2019-10245

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

時間媒介: CVSS:3.0/E:U/RL:O/RC:C

弱點資訊

CPE: cpe:2.3:a:ibm:java:*:*:*:*:*:*:*:*

必要的 KB 項目: installed_sw/Java

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2019/4/1

弱點發布日期: 2019/4/19

參考資訊

CVE: CVE-2019-10245