Scientific Linux 安全性更新:SL7.x i686/x86_64 上的 java-11-openjdk (2022:1440)

high Nessus Plugin ID 160059

Synopsis

遠端 Scientific Linux 主機缺少一個或多個安全性更新。

描述

遠端 Scientific Linux 7 主機上安裝的套件受到 SLSA-2022: 1440-1 公告中提及的多個弱點影響。

- OpenJDK:Apache Santuario 中缺失安全驗證 (程式庫,8278008) (CVE-2022-21476)

- OpenJDK:編譯特製 XPath 運算式時發生無限制的記憶體配置 (JAXP,8270504) (CVE-2022-21426)

- OpenJDK:AnnotationInvocationHandler 中存在不當的物件至字串轉換 (程式庫,8277672) (CVE-2022-21434)

- OpenJDK:缺少針對負 ObjectIdentifier 的檢查 (程式庫,8275151) (CVE-2022-21443)

- OpenJDK:URI 分析不一致 (JNDI,8278972) (CVE-2022-21496)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

更新受影響的套件。

另請參閱

https://www.scientificlinux.org/category/sl-errata/slsa-20221440-1

Plugin 詳細資訊

嚴重性: High

ID: 160059

檔案名稱: sl_20220420_java_11_openjdk_on_SL7_x.nasl

版本: 1.4

類型: local

代理程式: unix

已發布: 2022/4/21

已更新: 2022/5/6

支持的傳感器: Nessus Agent

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-21496

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

時間媒介: E:U/RL:O/RC:C

CVSS 評分資料來源: CVE-2022-21476

弱點資訊

CPE: cpe:/o:fermilab:scientific_linux, p-cpe:/a:fermilab:scientific_linux:java-11-openjdk, p-cpe:/a:fermilab:scientific_linux:java-11-openjdk-debuginfo, p-cpe:/a:fermilab:scientific_linux:java-11-openjdk-demo, p-cpe:/a:fermilab:scientific_linux:java-11-openjdk-devel, p-cpe:/a:fermilab:scientific_linux:java-11-openjdk-headless, p-cpe:/a:fermilab:scientific_linux:java-11-openjdk-javadoc, p-cpe:/a:fermilab:scientific_linux:java-11-openjdk-javadoc-zip, p-cpe:/a:fermilab:scientific_linux:java-11-openjdk-jmods, p-cpe:/a:fermilab:scientific_linux:java-11-openjdk-src, p-cpe:/a:fermilab:scientific_linux:java-11-openjdk-static-libs

必要的 KB 項目: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/4/20

弱點發布日期: 2022/4/17

參考資訊

CVE: CVE-2022-21426, CVE-2022-21434, CVE-2022-21443, CVE-2022-21476, CVE-2022-21496