GitLab < 14.4.5/14.5.0 < 14.5.3/14.6.0 < 14.6.1 不當驗證輸入

medium Nessus Plugin ID 159964

Synopsis

遠端 Web 伺服器上執行的來源控制應用程式受到一個不當驗證輸入弱點的影響。

描述

根據其自我報告的版本,遠端 Web 伺服器上執行的 GitLab 執行個體是早於 14.4.5、早於 14.5.3 的 14.5.0 或早於 14.6.2 的 14.6.0 版本。因此,其會受到與 Slack 整合有關的不當驗證輸入問題的影響,進而允許攻擊者建構惡意 URL 並透過 Slack 傳送這些 URL。

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 GitLab 14.4.5/14.5.3/14.6.1 或更新版本。

另請參閱

http://www.nessus.org/u?141c9a4d

Plugin 詳細資訊

嚴重性: Medium

ID: 159964

檔案名稱: gitlab_cve-2022-0124.nasl

版本: 1.4

類型: remote

系列: CGI abuses

已發布: 2022/4/20

已更新: 2022/7/26

風險資訊

VPR

風險因素: Low

分數: 1.4

CVSS v2

風險因素: Medium

基本分數: 4

時間分數: 3

媒介: AV:N/AC:L/Au:S/C:P/I:N/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-0124

CVSS v3

風險因素: Medium

基本分數: 4.3

時間分數: 3.8

媒介: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:gitlab:gitlab

必要的 KB 項目: installed_sw/GitLab

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2021/1/18

弱點發布日期: 2021/1/18

參考資訊

CVE: CVE-2022-0124

IAVA: 2022-A-0021-S