GitLab 11.9.x < 13.8.8/13.9.0 < 13.9.6/13.10.0 < 13.10.3 遠端程式碼執行

critical Nessus Plugin ID 159925

Synopsis

遠端網頁伺服器上執行的來源控制應用程式受到一個執行遠端程式碼弱點的影響。

描述

根據其自我報告的版本,遠端 Web 伺服器上執行的 GitLab 執行個體是早於 13.8.7 的 11.9.x 版本、早於 13.9.5 的 13.9.0 版本或早於 13.10.2 的 13.10.0 版本。因此,其會受到一個遠端程式碼執行弱點的影響,而這是由於第三方分析器中不當驗證圖像檔案所致。未經驗證的遠端攻擊者可利用此遠端命令執行弱點,破壞 GitLab 執行個體。

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 GitLab 13.8.8、13.9.6、13.10.3 或更新版本。

另請參閱

http://www.nessus.org/u?89a82423

Plugin 詳細資訊

嚴重性: Critical

ID: 159925

檔案名稱: gitlab_cve-2021-22205.nasl

版本: 1.4

類型: remote

系列: CGI abuses

已發布: 2022/4/20

已更新: 2022/7/26

風險資訊

VPR

風險因素: Critical

分數: 10

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:H/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-22205

CVSS v3

風險因素: Critical

基本分數: 10

時間分數: 9.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

時間媒介: E:H/RL:O/RC:C

弱點資訊

CPE: cpe:/a:gitlab:gitlab

必要的 KB 項目: installed_sw/GitLab

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2021/4/23

弱點發布日期: 2021/4/23

CISA 已知利用日期: 2021/11/17

惡意利用途徑

Metasploit (GitLab Unauthenticated Remote ExifTool Command Injection)

參考資訊

CVE: CVE-2021-22205

IAVA: 2021-A-0523-S