GitLab 11.1.0 < 14.2.6/11.2.0 < 14.3.4/11.3.0 < 14.4.1 核准繞過

medium Nessus Plugin ID 159921

Synopsis

遠端 Web 伺服器上執行的來源控制應用程式受到一個核准繞過弱點的影響。

描述

根據其自我報告的版本,遠端 Web 伺服器上執行的 GitLab 執行個體是早於 14.2.6 的 11.1.0 版本、早於 14.3.4 的 11.2.0 版本或早於 14.4.1 的 11.3.0 版本。因此,其會受到一個核准繞過弱點影響,進而允許攻擊者在極少數情況下繞過 CODEOWNERS 合併要求核准需求。

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 GitLab 14.2.6、14.3.4、14.4.1 或更新版本。

另請參閱

http://www.nessus.org/u?c8521058

Plugin 詳細資訊

嚴重性: Medium

ID: 159921

檔案名稱: gitlab_cve-2021-39909.nasl

版本: 1.4

類型: remote

系列: CGI abuses

已發布: 2022/4/20

已更新: 2022/7/26

風險資訊

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Low

基本分數: 3.5

時間分數: 2.6

媒介: AV:N/AC:M/Au:S/C:N/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-39909

CVSS v3

風險因素: Medium

基本分數: 5.3

時間分數: 4.6

媒介: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:gitlab:gitlab

必要的 KB 項目: installed_sw/GitLab

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2021/4/11

弱點發布日期: 2021/4/11

參考資訊

CVE: CVE-2021-39909

IAVA: 2021-A-0523-S