GitLab 14.4.x < 14.7.7/14.8.x < 14.8.5/14.9.x < 14.8.2 XSS

medium Nessus Plugin ID 159823

Synopsis

遠端 Web 伺服器上執行的來源控制應用程式受到一個跨網站指令碼弱點的影響。

描述

GitLab CE/EE 14.4 至 14.7.7、14.8 至 14.8.5 和 14.9 至 14.9.2 所有版本中存在不當中和使用者輸入問題,進而允許攻擊者透過在便簽中注入 HTML 來利用 XSS。

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 GitLab 14.7.7、14.8.5、14.9.2 或更新版本。

另請參閱

http://www.nessus.org/u?eea093a9

Plugin 詳細資訊

嚴重性: Medium

ID: 159823

檔案名稱: gitlab_cve-2022-1175.nasl

版本: 1.5

類型: remote

系列: CGI abuses

已發布: 2022/4/18

已更新: 2022/7/26

風險資訊

VPR

風險因素: Low

分數: 3.8

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.4

媒介: AV:N/AC:M/Au:N/C:N/I:P/A:N

時間媒介: E:POC/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-1175

CVSS v3

風險因素: Medium

基本分數: 6.1

時間分數: 5.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: cpe:/a:gitlab:gitlab

必要的 KB 項目: installed_sw/GitLab

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2022/3/31

弱點發布日期: 2022/3/31

參考資訊

CVE: CVE-2022-1175

IAVA: 2022-A-0131-S