Drupal 9.2.x < 9.2.16 / 9.3.x < 9.3.9 Drupal 弱點 (SA-CORE-2022-006)

high Nessus Plugin ID 159145

Synopsis

遠端 Web 伺服器上執行的 PHP 應用程式受到一個弱點影響。

描述

根據其自我報告的版本號碼,遠端網頁伺服器上執行的 Drupal 執行個體是早於 9.2.16 的 9.2.x 版或早於 9.3.9 的 9.3.x 版。因此,會受到一個弱點影響。

- guzzlehttp/psr7 是一個 PSR-7 HTTP 訊息程式庫。 1.8.4 和 2.1.1 之前的版本容易受到不當剖析標頭弱點的影響。攻擊者可偷偷加入新行字元並傳遞不受信任的值。此問題已在 1.8.4 和 2.1.1 版中修正。目前尚無已知的因應措施。(CVE-2022-24775)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 Drupal 9.2.16 / 9.3.9 版或更新版本。

另請參閱

https://www.drupal.org/sa-core-2022-006

https://github.com/guzzle/psr7/security/advisories/GHSA-q7rv-6hp3-vh96

https://www.drupal.org/node/1173280

https://www.drupal.org/project/drupal/releases/9.2.16

https://www.drupal.org/project/drupal/releases/9.3.9

https://www.drupal.org/psa-2021-06-29

Plugin 詳細資訊

嚴重性: High

ID: 159145

檔案名稱: drupal_9_3_9.nasl

版本: 1.4

類型: remote

系列: CGI abuses

已發布: 2022/3/22

已更新: 2022/4/26

組態: 啟用 Paranoid 模式, 啟用徹底檢查

風險資訊

VPR

風險因素: Medium

分數: 4.4

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-24775

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:drupal:drupal

必要的 KB 項目: installed_sw/Drupal, Settings/ParanoidReport

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/3/21

弱點發布日期: 2022/3/21

參考資訊

CVE: CVE-2022-24775