GitLab 13.x < 14.6.5 / 14.7.4 / 14.8.2 資訊洩漏

medium Nessus Plugin ID 158888

Synopsis

遠端 Web 伺服器執行的來源控制應用程式受到一個資訊洩漏弱點的影響。

描述

根據其自我報告的版本,遠端 Web 伺服器上執行的 GitLab 執行個體是早於 14.6.5 的 13.x 版本、早於 14.7.4 的 14.7.x 版本或早於 14.8.2 的 14.8.x 版本。因此,其會受到 GraphQL API 中一個資訊洩漏弱點的影響。未經驗證的遠端攻擊者可惡意利用此弱點,透過受影響的 API 列舉使用者。

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 GitLab 14.6.5、14.7.4、14.8.2 或更新版本。

另請參閱

http://www.nessus.org/u?35c16f9f

http://www.nessus.org/u?d774f0d1

Plugin 詳細資訊

嚴重性: Medium

ID: 158888

檔案名稱: gitlab_cve-2021-4191.nasl

版本: 1.2

類型: remote

系列: CGI abuses

已發布: 2022/3/14

已更新: 2022/3/15

風險資訊

VPR

風險因素: Low

分數: 2.9

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-4191

CVSS v3

風險因素: Medium

基本分數: 5.3

時間分數: 4.6

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:gitlab:gitlab

必要的 KB 項目: installed_sw/GitLab

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/2/25

弱點發布日期: 2022/2/25

參考資訊

CVE: CVE-2021-4191

IAVA: 2022-A-0099