Debian DLA-2935-1:expat - LTS 安全性更新

critical Nessus Plugin ID 158676

Synopsis

遠端 Debian 主機上缺少一個或多個安全性更新。

描述

遠端 Debian 9 主機上安裝的多個套件受到 dla-2935 公告中提及的多個弱點影響。

- 針對具有非零 XML_CONTEXT_BYTES 的組態, 2.4.4 版之前的 Expat (即 libexpat) 的 XML_GetBuffer 中有一個帶正負號的整數溢位弱點。(CVE-2022-23852)

- Expat (即 libexpat) 2.4.5 更早版本中的 xmltok_impl.c 缺少特定的編碼驗證處理,例如檢查 UTF-8 字元在特定內容中是否有效。(CVE-2022-25235)

- Expat (即 libexpat) 2.4.5 更早版本中的 xmlparse.c 允許攻擊者將命名空間分隔符號字元插入命名空間 URI。(CVE-2022-25236)

- 在 Expat (即 libexpat) 2.4.5 更早版本中,攻擊者可透過 DTD 元素中的大型巢狀深度,在 build_model 中觸發堆疊耗盡。(CVE-2022-25313)

- Expat (即 libexpat) 2.4.5 之前版本的 storeRawNames 中有一個整數溢位弱點。(CVE-2022-25315)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級 expat 套件。

針對 Debian 9「Stretch」,已在 2.2.0-2+deb9u5 版本中修正這些問題。

另請參閱

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1005894

https://security-tracker.debian.org/tracker/source-package/expat

https://www.debian.org/lts/security/2022/dla-2935

https://security-tracker.debian.org/tracker/CVE-2022-23852

https://security-tracker.debian.org/tracker/CVE-2022-25235

https://security-tracker.debian.org/tracker/CVE-2022-25236

https://security-tracker.debian.org/tracker/CVE-2022-25313

https://security-tracker.debian.org/tracker/CVE-2022-25315

https://packages.debian.org/source/stretch/expat

Plugin 詳細資訊

嚴重性: Critical

ID: 158676

檔案名稱: debian_DLA-2935.nasl

版本: 1.3

類型: local

代理程式: unix

已發布: 2022/3/7

已更新: 2022/5/25

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

VPR

風險因素: High

分數: 7.4

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.9

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:POC/RL:OF/RC:C

CVSS 評分資料來源: CVE-2022-25315

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.8

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:expat, p-cpe:/a:debian:debian_linux:lib64expat1, p-cpe:/a:debian:debian_linux:lib64expat1-dev, p-cpe:/a:debian:debian_linux:libexpat1, p-cpe:/a:debian:debian_linux:libexpat1-dev, cpe:/o:debian:debian_linux:9.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2022/3/7

弱點發布日期: 2022/1/24

參考資訊

CVE: CVE-2022-23852, CVE-2022-25235, CVE-2022-25236, CVE-2022-25313, CVE-2022-25315