PHP 7.4.x < 7.4.28

critical Nessus Plugin ID 158133

Synopsis

遠端 Web 伺服器上執行的 PHP 版本受到一個弱點影響。

描述

遠端主機上安裝的 PHP 版本為 7.4.28 之前的版本。因此,其會受到版本 7.4.28 公告中所提及的一個弱點影響。

- 在早於 7.4.28 的 PHP 7.4.x 版本、早於 8.0.16 的 PHP 8.0.x 版本以及早於 8.1.3 的 PHP 8.1.x 版本中使用具有 FILTER_VALIDATE_FLOAT 篩選器和最小/最大限制的篩選函式時,如果篩選失敗,則可能會觸發在釋放後使用已配置的記憶體,進而可能導致當機問題,並可能覆寫其他記憶體區塊和 RCE。此問題會影響:使用具有最小/最大限制的 FILTER_VALIDATE_FLOAT 的程式碼。
(CVE-2021-21708)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級至 PHP 7.4.28 版或更新版本。

另請參閱

http://php.net/ChangeLog-7.php#7.4.28

Plugin 詳細資訊

嚴重性: Critical

ID: 158133

檔案名稱: php_7_4_28.nasl

版本: 1.5

類型: remote

系列: CGI abuses

已發布: 2022/2/17

已更新: 2022/4/11

組態: 啟用徹底檢查

風險資訊

VPR

風險因素: Critical

分數: 9

CVSS v2

風險因素: Medium

基本分數: 6.8

時間分數: 5

媒介: AV:N/AC:M/Au:N/C:P/I:P/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS 評分資料來源: CVE-2021-21708

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: cpe:/a:php:php

必要的 KB 項目: www/PHP, installed_sw/PHP

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/2/17

弱點發布日期: 2022/2/17

參考資訊

CVE: CVE-2021-21708