Debian DLA-2887-1:lighttpd - LTS 安全性更新

high Nessus Plugin ID 156818

Synopsis

遠端 Debian 主機缺少安全性相關更新。

描述

遠端 Debian 9 主機上安裝的套件受 dla-2887 公告中提及的一個弱點影響。

- 在早於 1.4.50 的 lighttpd 版本的 mod_alias.c 的 mod_alias_physical_handler 內發現一個問題。在別名目標上方,單一目錄有個包含特定 mod_alias 組態的潛在 ../ 路徑周遊,其中比對的別名結尾缺少 ‘/’ 字元,但別名目標檔案系統路徑結尾有一個 ‘/’ 字元。(CVE-2018-19052)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級 lighttpd 套件。

針對 Debian 9「Stretch」,已在 1.4.45-1+deb9u1 版本中修正此問題。

另請參閱

https://security-tracker.debian.org/tracker/source-package/lighttpd

https://www.debian.org/lts/security/2022/dla-2887

https://security-tracker.debian.org/tracker/CVE-2018-19052

https://packages.debian.org/source/stretch/lighttpd

Plugin 詳細資訊

嚴重性: High

ID: 156818

檔案名稱: debian_DLA-2887.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2022/1/19

已更新: 2022/1/19

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

CVSS 評分資料來源: CVE-2018-19052

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:P/I:N/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:lighttpd, p-cpe:/a:debian:debian_linux:lighttpd-doc, p-cpe:/a:debian:debian_linux:lighttpd-mod-authn-gssapi, p-cpe:/a:debian:debian_linux:lighttpd-mod-authn-ldap, p-cpe:/a:debian:debian_linux:lighttpd-mod-authn-mysql, p-cpe:/a:debian:debian_linux:lighttpd-mod-cml, p-cpe:/a:debian:debian_linux:lighttpd-mod-geoip, p-cpe:/a:debian:debian_linux:lighttpd-mod-magnet, p-cpe:/a:debian:debian_linux:lighttpd-mod-mysql-vhost, p-cpe:/a:debian:debian_linux:lighttpd-mod-trigger-b4-dl, p-cpe:/a:debian:debian_linux:lighttpd-mod-webdav, cpe:/o:debian:debian_linux:9.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/1/18

弱點發布日期: 2018/11/7

參考資訊

CVE: CVE-2018-19052