Apache Druid Log4Shell 直接檢查 (CVE-2021-44228)

critical Nessus Plugin ID 156753

Synopsis

遠端網頁伺服器含有一個受到遠端程式碼執行弱點影響的 Java 應用程式。

描述

遠端 Web 伺服器上執行的 Apache Druid 版本受到隨附之 Apache Log4j 記錄程式庫中的一個遠端程式碼執行弱點影響。Apache Log4j 中存在弱點,這是由於在處理使用者控制的輸入時,對訊息查閱替換的保護不足所致。未經驗證的遠端攻擊者可利用此弱點,透過 Web 要求以正在執行之 Java 進程的權限級別執行任意程式碼。

此外掛程式要求掃描器和目標計算器皆可存取網際網路。

解決方案

升級至 Apache Druid 0.22.1 或更新版本。

另請參閱

http://www.nessus.org/u?7b651c6e

http://www.nessus.org/u?967acbea

Plugin 詳細資訊

嚴重性: Critical

ID: 156753

檔案名稱: apache_druid_log4shell.nbin

版本: 1.9

類型: remote

系列: CGI abuses

已發布: 2022/1/14

已更新: 2022/5/24

風險資訊

CVSS 評分資料來源: CVE-2021-44228

VPR

風險因素: Critical

分數: 10

CVSS v2

風險因素: High

基本分數: 9.3

時間分數: 8.1

媒介: AV:N/AC:M/Au:N/C:C/I:C/A:C

時間媒介: E:H/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 10

時間分數: 9.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

時間媒介: E:H/RL:O/RC:C

弱點資訊

CPE: cpe:/a:apache:druid

必要的 KB 項目: installed_sw/Apache Druid

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2021/12/16

弱點發布日期: 2021/12/10

CISA 已知利用日期: 2021/12/24

參考資訊

CVE: CVE-2021-44228

IAVA: 2021-A-0573, 0001-A-0650