Debian DSA-5042-1:epiphany-browser - 安全性更新

medium Nessus Plugin ID 156695

Synopsis

遠端 Debian 主機上缺少一個或多個安全性更新。

描述

遠端 Debian 11 主機上安裝的套件受 dsa-5042 公告中提及的多個弱點影響。

- 在 GNOME Web (又稱 Epiphany) 40.4 之前版本以及 41.1 之前的 41.x 版中,攻擊者可透過 about: 頁面執行 XSS 攻擊,如 ephy-about: overview 所示,當使用者造訪 XSS 裝載頁面足夠頻繁時, 應用程式會將此頁面加入「最常瀏覽」清單。(CVE-2021-45085)

- 在 GNOME Web (即 Epiphany) 中, 40.441.x ] 之前和 41.1 中可發生 XSS,這是因為伺服器的 supported_filename 在 PDF.js 中用作 pdf_name 值。 (CVE-2021-45086)

- 在 GNOME Web (即 Epiphany) 40.4 之前版本以及 41.1 之前的 41.x 版中,當使用「檢視來源」模式或「閱讀器」模式時,可能會發生 XSS,如頁面標題所示。(CVE-2021-45087)

- 在 GNOME Web (即 Epiphany) 40.4 之前版本以及 41.1 之前的 41.x 版中,攻擊者可透過錯誤頁面執行 XSS 攻擊。
(CVE-2021-45088)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

升級 epiphany-browser 套件。

針對穩定的發行版本 (bullseye),這些問題已在 3.38.2-1+deb11u1 版本中修正。

另請參閱

http://www.nessus.org/u?699d342c

https://www.debian.org/security/2022/dsa-5042

https://security-tracker.debian.org/tracker/CVE-2021-45085

https://security-tracker.debian.org/tracker/CVE-2021-45086

https://security-tracker.debian.org/tracker/CVE-2021-45087

https://security-tracker.debian.org/tracker/CVE-2021-45088

https://packages.debian.org/source/bullseye/epiphany-browser

Plugin 詳細資訊

嚴重性: Medium

ID: 156695

檔案名稱: debian_DSA-5042.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2022/1/13

已更新: 2022/1/13

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

CVSS 評分資料來源: CVE-2021-45088

VPR

風險因素: Low

分數: 3.8

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: AV:N/AC:M/Au:N/C:N/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Medium

基本分數: 6.1

時間分數: 5.3

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:epiphany-browser, p-cpe:/a:debian:debian_linux:epiphany-browser-data, cpe:/o:debian:debian_linux:11.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2022/1/12

弱點發布日期: 2021/12/16

參考資訊

CVE: CVE-2021-45085, CVE-2021-45086, CVE-2021-45087, CVE-2021-45088