Debian DLA-2860-1:paramiko - LTS 安全性更新

critical Nessus Plugin ID 156334

語系:

Synopsis

遠端 Debian 主機上缺少一個或多個安全性更新。

描述

遠端 Debian 9 主機上安裝的套件受 dla-2860 公告中提及的多個弱點影響。

在 Paramiko 2.4.1、2.3.2、2.2.3、2.1.5、2.0.8、1.18.5、1.17.6 版本中,SSH 伺服器中含有一個可導致 RCE 的錯誤存取控制弱點。此攻擊似乎可以透過網路連線發起。(CVE-2018-1000805)

- 針對 1.17.6 版之前的 Paramiko、1.18.5 版之前的 Paramiko 1.18.x、2.0.8 版之前的 Paramiko 2.0.x、2.1.5 版之前的 Paramiko 2.1.x、2.2.3 版之前的 Paramiko 2.2.x、2.3.2 版之前的 Paramiko 2.3.x 以及 2.4.1 版之前的 Paramiko 2.4.x, SSH 伺服器實作中的 transport.py 無法在處理其他要求前正確檢查驗證是否完成,channel-open 即為一例。自訂 SSH 用戶端可以略過驗證步驟。(CVE-2018-7750)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級 paramiko 套件。

針對 Debian 9「Stretch」,已在 2.0.0-1+deb9u1 版本中修正這些問題。

另請參閱

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=892859

https://security-tracker.debian.org/tracker/source-package/paramiko

https://www.debian.org/lts/security/2021/dla-2860

https://security-tracker.debian.org/tracker/CVE-2018-1000805

https://security-tracker.debian.org/tracker/CVE-2018-7750

https://packages.debian.org/source/stretch/paramiko

Plugin 詳細資訊

嚴重性: Critical

ID: 156334

檔案名稱: debian_DLA-2860.nasl

版本: 1.3

類型: local

代理程式: unix

已發布: 2021/12/28

已更新: 2022/1/20

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

CVSS 評分資料來源: CVE-2018-7750

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.5

時間分數: 5.9

媒介: AV:N/AC:L/Au:N/C:P/I:P/A:P

時間媒介: E:POC/RL:OF/RC:C

CVSS v3

風險因素: Critical

基本分數: 9.8

時間分數: 8.8

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

時間媒介: E:P/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:paramiko-doc, p-cpe:/a:debian:debian_linux:python-paramiko, p-cpe:/a:debian:debian_linux:python3-paramiko, cpe:/o:debian:debian_linux:9.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2021/12/28

弱點發布日期: 2018/3/13

參考資訊

CVE: CVE-2018-7750, CVE-2018-1000805