Debian DLA-2858-1:libzip - LTS 安全性更新

medium Nessus Plugin ID 156328

語系:

Synopsis

遠端 Debian 主機缺少安全性相關更新。

描述

遠端 Debian 9 主機上安裝的套件受 dla-2858 公告中提及的一個弱點影響。

- 在 1.3.0 之前版本的 libzip 中,zip_open.c 的 _zip_read_eocd64 函式無法正確處理 EOCD 記錄,這允許遠端攻擊者透過建構的 ZIP 封存造成拒絕服務 (無法在 zip_dirent.c 的 _zip_cdir_grow 中配置記憶體)。(CVE-2017-14107)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級 libzip 套件。

針對 Debian 9「Stretch」,已在 1.1.2-1.1+deb9u1 版本中修正此問題。

另請參閱

https://security-tracker.debian.org/tracker/source-package/libzip

https://www.debian.org/lts/security/2021/dla-2858

https://security-tracker.debian.org/tracker/CVE-2017-14107

https://packages.debian.org/source/stretch/libzip

Plugin 詳細資訊

嚴重性: Medium

ID: 156328

檔案名稱: debian_DLA-2858.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2021/12/28

已更新: 2021/12/28

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

CVSS 評分資料來源: CVE-2017-14107

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: AV:N/AC:M/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Medium

基本分數: 6.5

時間分數: 5.7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:libzip-dev, p-cpe:/a:debian:debian_linux:libzip4, p-cpe:/a:debian:debian_linux:zipcmp, p-cpe:/a:debian:debian_linux:zipmerge, p-cpe:/a:debian:debian_linux:ziptool, cpe:/o:debian:debian_linux:9.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2021/12/28

弱點發布日期: 2017/9/1

參考資訊

CVE: CVE-2017-14107