Debian DLA-2857-1:postgis - LTS 安全性更新

high Nessus Plugin ID 156321

語系:

Synopsis

遠端 Debian 主機缺少安全性相關更新。

描述

遠端 Debian 9 主機上安裝的套件受 dla-2857 公告中提及的一個弱點影響。

- 如果配合使用 2.3.3 版之前的 PostGIS 2.x 與 PostgreSQL,遠端攻擊者可以透過建構的 ST_AsX3D 函式輸入造成拒絕服務,SELECT ST_AsX3D('LINESTRING EMPTY') 發生異常伺服器終止即為一例;這是由於不當處理空白幾何圖形所致。(CVE-2017-18359)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級 postgis 套件。

針對 Debian 9「Stretch」,已在 2.3.1+dfsg-2+deb9u1 版本中修正此問題。

另請參閱

https://security-tracker.debian.org/tracker/source-package/postgis

https://www.debian.org/lts/security/2021/dla-2857

https://security-tracker.debian.org/tracker/CVE-2017-18359

https://packages.debian.org/source/stretch/postgis

Plugin 詳細資訊

嚴重性: High

ID: 156321

檔案名稱: debian_DLA-2857.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2021/12/27

已更新: 2021/12/27

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

CVSS 評分資料來源: CVE-2017-18359

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: High

基本分數: 7.5

時間分數: 6.5

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:liblwgeom-2.3-0, p-cpe:/a:debian:debian_linux:liblwgeom-dev, p-cpe:/a:debian:debian_linux:postgis, p-cpe:/a:debian:debian_linux:postgis-doc, p-cpe:/a:debian:debian_linux:postgis-gui, p-cpe:/a:debian:debian_linux:postgresql-9.6-postgis-2.3, p-cpe:/a:debian:debian_linux:postgresql-9.6-postgis-2.3-scripts, p-cpe:/a:debian:debian_linux:postgresql-9.6-postgis-scripts, cpe:/o:debian:debian_linux:9.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2021/12/28

弱點發布日期: 2019/1/25

參考資訊

CVE: CVE-2017-18359