Debian DLA-2850-1:libpcap - LTS 安全性更新

medium Nessus Plugin ID 156318

Synopsis

遠端 Debian 主機缺少安全性相關更新。

描述

遠端 Debian 9 主機上安裝的套件受 dla-2850 公告中提及的一個弱點影響。

- libpcap 1.9.1 之前版本中的 sf-pcapng.c 在配置記憶體之前,未正確驗證 PHB 標頭長度。(CVE-2019-15165)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級 libpcap 套件。

針對 Debian 9「Stretch」,已在 1.8.1-3+deb9u1 版本中修正此問題。

另請參閱

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=941697

https://security-tracker.debian.org/tracker/source-package/libpcap

https://www.debian.org/lts/security/2021/dla-2850

https://security-tracker.debian.org/tracker/CVE-2019-15165

https://packages.debian.org/source/stretch/libpcap

Plugin 詳細資訊

嚴重性: Medium

ID: 156318

檔案名稱: debian_DLA-2850.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2021/12/27

已更新: 2021/12/27

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

CVSS 評分資料來源: CVE-2019-15165

VPR

風險因素: Low

分數: 2.2

CVSS v2

風險因素: Medium

基本分數: 5

時間分數: 3.7

媒介: AV:N/AC:L/Au:N/C:N/I:P/A:N

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Medium

基本分數: 5.3

時間分數: 4.6

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:libpcap-dev, p-cpe:/a:debian:debian_linux:libpcap0.8, p-cpe:/a:debian:debian_linux:libpcap0.8-dbg, p-cpe:/a:debian:debian_linux:libpcap0.8-dev, cpe:/o:debian:debian_linux:9.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2021/12/26

弱點發布日期: 2019/10/3

參考資訊

CVE: CVE-2019-15165