Debian DLA-2851-1:libextractor - LTS 安全性更新

medium Nessus Plugin ID 156314

Synopsis

遠端 Debian 主機缺少安全性相關更新。

描述

遠端 Debian 9 主機上安裝的套件受 dla-2851 公告中提及的一個弱點影響。

- 在 GNU Libextractor 1.9 及之前版本中,plugins/dvi_extractor.c 的 EXTRACTOR_dvi_extract_method 函式中存在堆積型緩衝區過度讀取。(CVE-2019-15531)

請注意,Nessus 並未測試此問題,而是僅依據應用程式自我報告的版本號碼。

解決方案

升級 libextractor 套件。

針對 Debian 9「Stretch」,已在版本 1 中修正此問題

另請參閱

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=935553

http://www.nessus.org/u?bd14df80

https://www.debian.org/lts/security/2021/dla-2851

https://security-tracker.debian.org/tracker/CVE-2019-15531

https://packages.debian.org/source/stretch/libextractor

Plugin 詳細資訊

嚴重性: Medium

ID: 156314

檔案名稱: debian_DLA-2851.nasl

版本: 1.2

類型: local

代理程式: unix

已發布: 2021/12/27

已更新: 2021/12/27

支持的傳感器: Frictionless Assessment Agent, Nessus Agent

風險資訊

CVSS 評分資料來源: CVE-2019-15531

VPR

風險因素: Low

分數: 3.6

CVSS v2

風險因素: Medium

基本分數: 4.3

時間分數: 3.2

媒介: AV:N/AC:M/Au:N/C:N/I:N/A:P

時間媒介: E:U/RL:OF/RC:C

CVSS v3

風險因素: Medium

基本分數: 6.5

時間分數: 5.7

媒介: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

時間媒介: E:U/RL:O/RC:C

弱點資訊

CPE: p-cpe:/a:debian:debian_linux:extract, p-cpe:/a:debian:debian_linux:libextractor-dbg, p-cpe:/a:debian:debian_linux:libextractor-dev, p-cpe:/a:debian:debian_linux:libextractor3, cpe:/o:debian:debian_linux:9.0

必要的 KB 項目: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可輕鬆利用: No known exploits are available

修補程式發佈日期: 2021/12/26

弱點發布日期: 2019/8/23

參考資訊

CVE: CVE-2019-15531