Apache Log4Shell CVE-2021-45046 繞過遠端程式碼執行

critical Nessus Plugin ID 156164

Synopsis

遠端伺服器上執行的 Apache Log4j 版本受到遠端程式碼執行弱點影響。

描述

早於 2.16.0 的 Apache Log4j 版本中存在一個遠端程式碼執行弱點,這是由於在處理使用者控制的輸入時,對訊息查閱替換的保護不足所致。未經驗證的遠端攻擊者可利用此弱點,透過 Web 要求以正在執行之 Java 進程的權限級別執行任意程式碼。

請注意,此繞過需要完成非預設組態。只有具有內容查閱 (例如,$${ctx: loginId}) 的模式配置易受此弱點影響。

此外掛程式要求掃描器和目標計算器皆可存取網際網路。

解決方案

升級至 Apache Log4j 2.16.0 或更高版本,或者採用廠商的緩解措施。

強烈建議升級至 Apache Log4j 最新版本,因為中繼版本/修補程式中存在已知的高嚴重性弱點,而且供應商會經常在發現與 Log4j 相關的新研究和新知識時更新其公告。請參閱 https://logging.apache.org/log4j/2.x/security.html 了解最新版本。

另請參閱

https://logging.apache.org/log4j/2.x/security.html

https://www.lunasec.io/docs/blog/log4j-zero-day/

http://www.nessus.org/u?a0e621e5

Plugin 詳細資訊

嚴重性: Critical

ID: 156164

檔案名稱: apache_log4shell_CVE-2021-45056_direct_check.nbin

版本: 1.15

類型: remote

系列: Web Servers

已發布: 2021/12/17

已更新: 2022/8/15

風險資訊

CVSS 評分論據: Nvd has not updated their score yet

VPR

風險因素: Critical

分數: 9.9

CVSS v2

風險因素: High

基本分數: 9.3

媒介: AV:N/AC:M/Au:N/C:C/I:C/A:C

CVSS 評分資料來源: manual

CVSS v3

風險因素: Critical

基本分數: 9

媒介: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H

弱點資訊

CPE: cpe:/a:apache:log4j

修補程式發佈日期: 2021/12/10

弱點發布日期: 2021/12/9

參考資訊

CVE: CVE-2021-45046

IAVA: 2021-A-0573, 2021-A-0598, 0001-A-0650