RHEL 8:kernel-rt (RHSA-2021: 4140)

high Nessus Plugin ID 155172

概要

遠端 Red Hat 主機缺少一個或多個安全性更新。

說明

遠端 Redhat Enterprise Linux 8 主機上安裝的套件受到 RHSA-2021:4140 公告中提及的多個弱點影響。

- 核心:Intel 圖形卡資訊洩漏。(CVE-2019-14615)

- 核心:pinctrl 子系統中存在超出邊界讀取弱點。(CVE-2020-0427)

- 核心:某些 Intel(R) Ethernet E810 Adapter 驅動程式中存在輸入驗證不當問題 (CVE-2020-24502)

- 核心:某些 Intel(R) Ethernet E810 Adapter 驅動程式中不足的存取控制 (CVE-2020-24503)

- 核心:某些 Intel(R) Ethernet E810 Adapter 驅動程式中不受控制的資源消耗 (CVE-2020-24504)

- 核心:重新連線時未清除片段快取 (CVE-2020-24586)

- 核心:重組在不同金鑰下加密的片段 (CVE-2020-24587)

- 核心:wifi 框架承載被錯誤剖析為 L2 框架 (CVE-2020-24588)

- 核心:從未經驗證的 wifi 用戶端轉送 EAPOL (CVE-2020-26139)

- 核心:在受保護的網路中接受純文字資料框架 (CVE-2020-26140)

- 核心:不驗證片段框架的 TKIP MIC (CVE-2020-26141)

- 核心:在受保護的網路中接受分散式純文字框架 (CVE-2020-26143)

- 核心:接受以 RFC1042 標頭開頭的未加密 A-MSDU 框架 (CVE-2020-26144)

- 核心:接受純文字廣播片段作為完整框架 (CVE-2020-26145)

- 核心:重組具有非連續封包編號的加密片段 (CVE-2020-26146)

- 核心:重組混合的加密/純文字片段 (CVE-2020-26147)

- 核心:由於 THP mapcount 檢查中存在爭用情形,寫入時複製實作可授予非預定的寫入存取權 (CVE-2020-29368)

- 核心:drivers/tty/tty_io.c 和 drivers/tty/tty_jobctrl.c 中的鎖定不一致會導致釋放後讀取 (CVE-2020-29660)

- 核心:在 drivers/net/wireless/marvell/mwifiex/join.c 的 mwifiex_cmd_802_11_ad_hoc_start 函式中,透過長 SSID 值發生緩衝區溢位 (CVE-2020-36158)

- 核心:在 virt/kvm/kvm_main.c 的 kvm_io_bus_unregister_dev 函式中執行 kmalloc 失敗時發生記憶體洩漏 (CVE-2020-36312)

- 核心:net/bluetooth/hci_event.c 的 hci_extended_inquiry_result_evt() 中的 slab 超出邊界讀取 (CVE-2020-36386)

- 核心:BlueZ 中不當的存取控制可能導致資訊洩漏弱點。(CVE-2021-0129)

- 核心:__cgroup_bpf_run_filter_getsockopt() 中的堆積溢位 (CVE-2021-20194)

- 核心:setsockopt 系統呼叫未受信任的指標解除參照資訊洩漏 (CVE-2021-20239)

- 核心:sctp_destroy_sock list_del 中的爭用情形 (CVE-2021-23133)

- 核心:fuse:由於重試迴圈不斷發現相同的錯誤 inode,可能會發生 CPU 停頓問題 (CVE-2021-28950)

- 核心:在 arch/x86/events/intel/ds.c 中的 intel_pmu_drain_pebs_nhm 發生系統當機 (CVE-2021-28971)

- 核心:可能繞過推測超出邊界載入的指標算術作業序列保護,以洩漏核心記憶體的內容 (CVE-2021-29155)

- 核心:net/tipc/node.c 中的 tipc_nl_retrieve_key 函式中的不當輸入驗證 (CVE-2021-29646)

- 核心:在 net/netfilter/x_tables.c 和 include/linux/netfilter/x_tables.h 中指派新表格值時缺少完整的記憶體屏障,可導致 DoS (CVE-2021-29650)

- 核心:處理 eBPF 程式時的本機權限提升 (CVE-2021-31440)

- 核心:可能繞過推測指標算術的堆疊指標保護,以洩漏核心記憶體的內容 (CVE-2021-31829)

- 核心:drivers/md/dm-ioctl.c 中的超出邊界陣列存取 (CVE-2021-31916)

- 核心:net/ipv4/cipso_ipv4.c 中 cipso_v4_genopt 發生釋放後使用 (CVE-2021-33033)

- 核心:因 BPF 驗證程式對指標算術作業強制執行不正確的限制,而導致超出邊界讀取和寫入 (CVE-2021-33200)

- 核心:drivers/block/nbd.c 的 ndb_queue_rq() 中的釋放後使用 (CVE-2021-3348)

- 核心:Linux 核心 eBPF RINGBUF 對應過大配置 (CVE-2021-3489)

- 核心:HCI 裝置初始化失敗時,藍牙子系統中的雙重釋放 (CVE-2021-3564)

- 核心:函式 hci_sock_bound_ioctl() 中的釋放後使用 (CVE-2021-3573)

- 核心:div/mod 上的 eBPF 32 位元來源暫存器截斷 (CVE-2021-3600)

- 核心:在 lib/list_debug.c:50 存在流程表清單 del 損毀和核心錯誤50 (CVE-2021-3635)

- 核心:net/mac802154/llsec.c 的 llsec_key_alloc() 中的 NULL 指標解除參照 (CVE-2021-3659)

- 核心:rb_per_cpu_empty() 中的 DoS (CVE-2021-3679)

- 核心:overlayfs:在無權限的使用者命名空間內掛載 overlayfs 可能會洩漏檔案 (CVE-2021-3732)

請注意,Nessus 並未測試這些問題,而是僅依據應用程式自我報告的版本號碼作出判斷。

解決方案

更新受影響的套件。

另請參閱

https://access.redhat.com/security/cve/CVE-2019-14615

https://access.redhat.com/security/cve/CVE-2020-0427

https://access.redhat.com/security/cve/CVE-2020-24502

https://access.redhat.com/security/cve/CVE-2020-24503

https://access.redhat.com/security/cve/CVE-2020-24504

https://access.redhat.com/security/cve/CVE-2020-24586

https://access.redhat.com/security/cve/CVE-2020-24587

https://access.redhat.com/security/cve/CVE-2020-24588

https://access.redhat.com/security/cve/CVE-2020-26139

https://access.redhat.com/security/cve/CVE-2020-26140

https://access.redhat.com/security/cve/CVE-2020-26141

https://access.redhat.com/security/cve/CVE-2020-26143

https://access.redhat.com/security/cve/CVE-2020-26144

https://access.redhat.com/security/cve/CVE-2020-26145

https://access.redhat.com/security/cve/CVE-2020-26146

https://access.redhat.com/security/cve/CVE-2020-26147

https://access.redhat.com/security/cve/CVE-2020-29368

https://access.redhat.com/security/cve/CVE-2020-29660

https://access.redhat.com/security/cve/CVE-2020-36158

https://access.redhat.com/security/cve/CVE-2020-36312

https://access.redhat.com/security/cve/CVE-2020-36386

https://access.redhat.com/security/cve/CVE-2021-0129

https://access.redhat.com/security/cve/CVE-2021-3348

https://access.redhat.com/security/cve/CVE-2021-3489

https://access.redhat.com/security/cve/CVE-2021-3564

https://access.redhat.com/security/cve/CVE-2021-3573

https://access.redhat.com/security/cve/CVE-2021-3600

https://access.redhat.com/security/cve/CVE-2021-3635

https://access.redhat.com/security/cve/CVE-2021-3659

https://access.redhat.com/security/cve/CVE-2021-3679

https://access.redhat.com/security/cve/CVE-2021-3732

https://access.redhat.com/security/cve/CVE-2021-20194

https://access.redhat.com/security/cve/CVE-2021-20239

https://access.redhat.com/security/cve/CVE-2021-23133

https://access.redhat.com/security/cve/CVE-2021-28950

https://access.redhat.com/security/cve/CVE-2021-28971

https://access.redhat.com/security/cve/CVE-2021-29155

https://access.redhat.com/security/cve/CVE-2021-29646

https://access.redhat.com/security/cve/CVE-2021-29650

https://access.redhat.com/security/cve/CVE-2021-31440

https://access.redhat.com/security/cve/CVE-2021-31829

https://access.redhat.com/security/cve/CVE-2021-31916

https://access.redhat.com/security/cve/CVE-2021-33033

https://access.redhat.com/security/cve/CVE-2021-33200

https://access.redhat.com/errata/RHSA-2021:4140

https://bugzilla.redhat.com/1789209

https://bugzilla.redhat.com/1903244

https://bugzilla.redhat.com/1906522

https://bugzilla.redhat.com/1912683

https://bugzilla.redhat.com/1913348

https://bugzilla.redhat.com/1919893

https://bugzilla.redhat.com/1921958

https://bugzilla.redhat.com/1923636

https://bugzilla.redhat.com/1930376

https://bugzilla.redhat.com/1930379

https://bugzilla.redhat.com/1930381

https://bugzilla.redhat.com/1941762

https://bugzilla.redhat.com/1941784

https://bugzilla.redhat.com/1945345

https://bugzilla.redhat.com/1945388

https://bugzilla.redhat.com/1946965

https://bugzilla.redhat.com/1947991

https://bugzilla.redhat.com/1948772

https://bugzilla.redhat.com/1951595

https://bugzilla.redhat.com/1957788

https://bugzilla.redhat.com/1959559

https://bugzilla.redhat.com/1959642

https://bugzilla.redhat.com/1959654

https://bugzilla.redhat.com/1959657

https://bugzilla.redhat.com/1959663

https://bugzilla.redhat.com/1960490

https://bugzilla.redhat.com/1960492

https://bugzilla.redhat.com/1960496

https://bugzilla.redhat.com/1960498

https://bugzilla.redhat.com/1960500

https://bugzilla.redhat.com/1960502

https://bugzilla.redhat.com/1960504

https://bugzilla.redhat.com/1961300

https://bugzilla.redhat.com/1964028

https://bugzilla.redhat.com/1964139

https://bugzilla.redhat.com/1965038

https://bugzilla.redhat.com/1965458

https://bugzilla.redhat.com/1966578

https://bugzilla.redhat.com/1969489

https://bugzilla.redhat.com/1975949

https://bugzilla.redhat.com/1976946

https://bugzilla.redhat.com/1981954

https://bugzilla.redhat.com/1989165

https://bugzilla.redhat.com/1995249

Plugin 詳細資訊

嚴重性: High

ID: 155172

檔案名稱: redhat-RHSA-2021-4140.nasl

版本: 1.7

類型: local

代理程式: unix

已發布: 2021/11/11

已更新: 2024/1/16

支援的感應器: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

風險資訊

VPR

風險因素: Medium

分數: 6.7

CVSS v2

風險因素: High

基本分數: 7.2

時間分數: 6

媒介: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS 評分資料來源: CVE-2021-3489

CVSS v3

風險因素: High

基本分數: 7.8

時間分數: 7.2

媒介: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

時間媒介: CVSS:3.0/E:F/RL:O/RC:C

CVSS 評分資料來源: CVE-2021-3600

弱點資訊

CPE: cpe:/o:redhat:enterprise_linux:8, cpe:/o:redhat:rhel_aus:8.6, cpe:/o:redhat:rhel_e4s:8.6, cpe:/o:redhat:rhel_eus:8.6, cpe:/o:redhat:rhel_tus:8.6, p-cpe:/a:redhat:enterprise_linux:kernel-rt, p-cpe:/a:redhat:enterprise_linux:kernel-rt-core, p-cpe:/a:redhat:enterprise_linux:kernel-rt-debug, p-cpe:/a:redhat:enterprise_linux:kernel-rt-debug-core, p-cpe:/a:redhat:enterprise_linux:kernel-rt-debug-devel, p-cpe:/a:redhat:enterprise_linux:kernel-rt-debug-kvm, p-cpe:/a:redhat:enterprise_linux:kernel-rt-debug-modules, p-cpe:/a:redhat:enterprise_linux:kernel-rt-debug-modules-extra, p-cpe:/a:redhat:enterprise_linux:kernel-rt-devel, p-cpe:/a:redhat:enterprise_linux:kernel-rt-kvm, p-cpe:/a:redhat:enterprise_linux:kernel-rt-modules, p-cpe:/a:redhat:enterprise_linux:kernel-rt-modules-extra

必要的 KB 項目: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

可被惡意程式利用: true

可輕鬆利用: Exploits are available

修補程式發佈日期: 2021/11/9

弱點發布日期: 2020/1/15

參考資訊

CVE: CVE-2019-14615, CVE-2020-0427, CVE-2020-24502, CVE-2020-24503, CVE-2020-24504, CVE-2020-24586, CVE-2020-24587, CVE-2020-24588, CVE-2020-26139, CVE-2020-26140, CVE-2020-26141, CVE-2020-26143, CVE-2020-26144, CVE-2020-26145, CVE-2020-26146, CVE-2020-26147, CVE-2020-29368, CVE-2020-29660, CVE-2020-36158, CVE-2020-36312, CVE-2020-36386, CVE-2021-0129, CVE-2021-20194, CVE-2021-20239, CVE-2021-23133, CVE-2021-28950, CVE-2021-28971, CVE-2021-29155, CVE-2021-29646, CVE-2021-29650, CVE-2021-31440, CVE-2021-31829, CVE-2021-31916, CVE-2021-33033, CVE-2021-33200, CVE-2021-3348, CVE-2021-3489, CVE-2021-3564, CVE-2021-3573, CVE-2021-3600, CVE-2021-3635, CVE-2021-3659, CVE-2021-3679, CVE-2021-3732

CWE: 119, 120, 125, 20, 200, 212, 252, 287, 290, 307, 345, 346, 362, 400, 415, 416, 476, 662, 667, 682, 772, 787, 822, 829, 835, 863

IAVA: 2021-A-0222-S, 2021-A-0223-S

RHSA: 2021:4140